Roon Extension: Deep Harmony - rich feature set for Logitech Harmony

Deep harmony is a docker only extension, you can’t install or manage docker extensions unless the extension manger is itself run as docker.

Just got this extension working. I’m also wondering if I could get the command line to run in the background. Might be easier to run the Dockerized version of the script and figure out how to run it on startup.

On a side note, has anybody been able to connect the Hub directly to a “Remote In” jack? I tried this with my Yamaha A-S1100 and it didn’t register any commands that work via IR.

Edit: It was a bad cable. Hub to Remote In is working fine now as a great IR-free solution. I also recommend mapping Mute to ToggleOn/Off to get power control in the Roon app. I use that more often and never have to open Harmony now.

I’m getting this constantly on a Mac Mini, in an endless loop. Deep Harmony is in my Whitelist. The only way to fix it is to quit Terminal and re-boot the Mac, then the extension works for a day and goes back into the endless loop. I can’t click “Allow” before another instance occurs, so I can never get to the point where I tell the extension that it can “accept incoming connections”

Any ideas what I can do?

Screen Shot 2020-07-07 at 10.56.52 Screen Shot 2020-07-07 at 10.57.09

@Dan_Brown You might try changing the run script command to auto-accept any prompts it encounters or possibly change the security permissions of the script file prior to running. If neither of those work try using Docker implementation of the script.

Thanks @Anders_Bergren. Please excuse me for being dumb, but how do I do that? Is there an online resource you can point me to that explains it?

Thanks, Dan.

1 Like

I have a problem with volume on another extension - web remote.
It can’t handle volume control when the volume is set to Deep Harmony.
See bellow post.
Any thoughts ?
Thank you

rolskiRoland I need an idiots’ guide to installing this extension on a Roon Rock system (Intel NUC).

I have the Roon Extension Manager installed on a windows machine and Roon sees it - showing an extension “The Appgineer.” That extension offers another extension to control the Harmony Hub called “Doc Bobo.” How in the world do I get the extension “Deep Harmony”?

Background: I’m trying my hand with a Windows 10 machine before plunking down another $100 or so on a new Raspberry Pi, case, power supply, SD card… So I finally got the Extension Manager to run as a Windows service, and it appears in Roon as “The Appgineer.” I wanted to install Deep Harmony, but The Appgineer only offers an extension known as “Doc Bobo.” That extension does not recognize my Harmony Hub. I have a FLIRC plugged into my Raspberry Pi with a touchscreen. That Touchscreen Pi can and does control Roon music. It shows what’s playing and you can skip songs using it. Not much else. The FLIRC which is plugged into it is as it came from the box. (I have no physical remote to be configured.) The web interface for the Touchscreen Pi “sees” the FLIRC. The Harmony Hub is situated right next to the FLIRC, and it is plugged in.
What now?

If an Idiot’s Guide exists, I certainly could have used it but never found it. I cannot be of much help for your Intel NUC installation except to say that once I finally got the thing working, I do like having it. Although, as far as I’m concerned, 90%+ of the Harmony Hub value is there even without the added Deep Harmony functions. The volume and transport controls added by DH might not be worth the hassle for most users. YMMV.

Use Extension Manager to install Deep Harmony. It’s under Remote Control.

Leave the FLIRC out of the mix for now. Focus on getting DH setup and configured and controlling Roon.

I am returning the Harmony Hub and the FLIRC. I have ordered a new Raspberry Pi and will assemble it with Diet Pi. That Pi will be my “extension server.”

You’ll still need the Harmony Hub if you wish to use the Deep Harmony extension.

Now what have I forgotten? I’ve been running Deep Harmony successfully for a long time to control two Harmony hubs, one in the sitting room and one in the kitchen. I changed the Room endpoint in the kitchen, and enabled the extension in the new device setup and at first everything just worked fine. Great.

But something has happened, and now the connection between DH and The Harmony hub seems to work just one way, and partially at that. What I mean is that if I start playing Roon to the kitchen, DH will tell Harmony to start the relevant amp, but it no longer switches the input. And if I use the Harmony remote to pause/play/skip forward/skip back then those instructions from Harmony don’t get through to DH - or at least they don’t seem to because Roon doesn’t respond to them.

I must be missing something obvious. Any suggestions? Thanks

Can I do something to fool the DH extension into thinking there is a Hub? What does the hub do anyway?

It’s a bridge between the handheld Harmony remote, or your smartphone app, and the IR/WiFi/Bluetooth signals your components need to receive. It is a more versatile alternative to universal remotes that only emit IR signals (which typically are trained to mimic the IR signals sent by each IR remote that came with your devices.)

And if I don’t want a hand-held remote…? I only want voice commands from Alexa. I have plenty of phones and tablets around that can control Roon.

Bizarre, I don’t see it listed as an install option for me using Extension Manager.

Edit: I see from the repository list [here]( that it is only available if running in a Docker scenario, which I am not.

Whoops - it did change the input

Answering my own question here - I found that DH settings for the activity had no Remote control zone set. Doh!

I have moved my Harmony Hub to a position next to an Android Tablet that I use to control Roon. The hub and the tablet “talk” to each other through both blue-tooth and the LAN. I have the Deep Harmony extension installed in Roon. I have the Harmony skill enabled in Alexa. I have used the Harmony Android application to set things up. I tried setting an “activity” there in the Android app for “stereo.” I was given very few choices for that “activity” - I told the app I was using a “computer” and that the OS was “other.” I was able to name the activity “stereo” and I picked an icon for it.
That was about all there was to enter into that “activity.” Getting all these parts to work in “harmony” with each other is a fantastic challenge. That plus even if I have been successful in orchestrating this, I have no idea what commands I can give to Alexa when all is said and done…

Anyone have an idea of an Alexa command that I can try in order for me to test if I might have succeeded and don’t even realize it?

How do you set these Deep Harmony extension settings?

This extension is a docker only, so you need to install a docker version of the extension manager and also need to set the docker socket I did it following the same instructions as the cdripper for extension manager.

Sorry, but I’m too ignorant to understand how to do this. You’re talking a different language :confused:. How do you “set the docker socket”? Where do you find instructions for installing the CD Ripper for extension manager?