Roon iOS 12.1.3 crash on startup

#1

I just updated iOS to 12.1.3, Roon (1.6), & Roon Remote (also 1.6). This is on an iPad Air 2 that has been happily running Roon Remote for several years, until tonight.

Roon Remote crashes on startup: the Roon logo comes up, the screen goes black, and after a few seconds I’m back at the home screen.

I’ve tried rebooting; no luck.

@support please help!

Thanks!

(Mr Fix It ) #2

Did you try removing and reinstalling the app

(Max Delissen) #3

Same problem here, on iPad Air.

Un-/reinstall didn’t do the trick.

No problem on iPhone 7.

Following…

Edit: intermittendly it will open, but after a while it will close again unexpectedly…

Edit 2: Closing down and restarting RoonServer on my dedicated Mac mini (without actually restarting the Mac mini itself) seems to work for now, but had to do that yesterday too.

#4

Yeah, I had the same problem on an iPad Mini. Additionally, after the iPad came back from being asleep, the Roon app was locked up.

Deleting and re-installing the app seems to have worked.

(Steve Schaffer) #5

Works fine on updated iPhone X with Roon 1.6.

Cannot even start the app on iPad Pro 2018 12.9", an older iPad and yet another, even older one. Just installed on an iPad Mini.

Also, iMac crashes immediately. Same on MacMini. Also, just tried installing it on an older MacBook Pro and it allowed me to find the Nucleus and connect. But when I chose a zone it crashed. Any attempt to launch it again caused the app to crash. For grins I used the same MacBook but launched Win10 under BootCamp. Installed Roon and it got as far as asking for Zone. Once picked it crashed. Subsequent attempts to launch the app reveals the black box with roon and the random quote, a white box appears with red X across it and then crashes Likely this is different than Mac environments due to the fact of Win10 implementation and slower laptop.

Thinking it might be my network, I powered off my cable modem to Comcast as well as WiFi access point devices. Powered the cable modem on and waited a bit. Then the access points. No change in situation.

What can I do to find the source of the problem?

Update: tracked the problem to the dCS Upsampler. When I installed the app on the iPad Mini rather than immediately pointing it at my dCS Zone, I tried a couple others. They worked without a problem. So, isolating to the dCS Zone, I restarted the Upsampler along with the DAC. After that, all is well.
No idea why everything was OK yesterday, but suddenly went crazy today.

#6

Update: the app “just works” in the very best tradition of Roon Labs & Apple on my iPhone Xs.

I tried deleting & re-installing; it asked me to accept the privacy policy, but has a hard time finding my core. Trying again right now, it finally worked, so we’ll see how long it lasts…

Good luck everyone!

(Binky) #7

Roon is working fine for me, but I have another app (Audible) that has worked perfectly on my iPad for years and now crashes on latest iOS update whilst working fine on my iPhone running same iOS version, so something has been updated and broken a few apps… thankfully Roon is still working :sunglasses:

#8

It’s still working for me, so perhaps this is the first known case of “software break in?” The NAND flash cells just needed to relax…:sunglasses: (FWIW, I have a Ph.D. in Computer Science & decades of experience.)

More seriously: it sounds like there’s an issue impacting a small number of folks. Debugging something that’s hard to reproduce is a royal pain (been there, done that, got the t-shirt). Hopefully this will be addressed in the next release— it was unfortunate that iOS and Roon released within a day of each other.

(Noris) split this topic #9

A post was merged into an existing topic: Audiophile Baroque Station Causes Roon To Crash

(Noris) #10

Hello All,

We have just released Roon v1.6 build 401 which addresses a few possible causes of this issue:

Roon 1.6 (Build 401) Is Live! Software Release Notes

Hi everyone! A new maintenance release is now rolling out for all platforms, with bug fixes, performance improvements, and updated designs for some of the UI changes in Roon 1.6. Today’s release includes a number of refinements for the footer and the Now Playing screen. We’ve heard a lot of great feedback on the changes in Roon 1.6, and we think the changes made over the last few weeks are big improvement. We hope you agree and we’re looking forward to hearing from everyone! We’ve added the m…

Please give the update a try and let me know how it goes!

Thanks,
Noris