Roon no longer sees my SB# or Transporter

I don’t know if this will work for you, and it runs counter to most advice, but it worked for me when my Squeezebox would disappear. I’d reinstall LMS and get it going long enough to establish a connection to the SBT. Once I could play music, I’d shut down LMS and restart Roon. Every time the SBT would show up after that. It’s like the SBT itself was having trouble getting on the network until I reconnected it to LMS. Your mileage may vary.

Interesting. If all else fails, I will try that. Very frustrating kind of issue.

Up and running!!!

I deleted Roon, reinstalled, rebooted, and voila.

Thanks for the input. Now, I am going to stop beating my head against a wall and listen to some music. Take care.

realize you’re fixed now, but i wonder if the LMS-lite on the touch was the problem. if it happens again, you might try unplugging the touch, and seeing if the TP will connect to roon.

1 Like

Strange. I just had my transporter, SB Radio, and SB Touch disappear from Roon. Roonbridge connections all remained intact. Rebooted everything and couldn’t see the squeezeboxes. disabling re-enabling squeezebox support did nothing. Manually re-setting up each device individually (i.e. choosing the Roon Library again from each SB) had them immediately come on line again. No LMS server is running here and everything is wired gigabit. So, for some reason, all three squeezebox devices disconnected and needed to be re setup again at the same time.

I’ve been without any sign of my squeezeboxes (duet, 2 receivers) since the update to 1.3 (269) and they also didn’t show again when I got back to build 259. I’m on MacOS 10.12.6 . Your advice worked perfectly. Thank you!! What I did:

  1. In Roon Settings under Setup DISABLE Squeezebox-support.
  2. Remove LMS from the preference pane and dump it permanently.
  3. Download and install newest version of LMS from
  4. Start server from preference pane
  5. With SB Controller get SB to connect to the mac and play some music
  6. Stop Server in preference pane
  7. Enable squeezebox supprt in Roon
    Thx again!
1 Like