Roon on windows10 machine cannot connect to rock

I have recently installed ROCK on a NUC. I have two windows machines; one of them has no problem connecting to ROCK, the other one finds this very difficult. And difficult means it sees the ROCK instance, I click connect and then it will do nothing anymore. Windows give me the message ’ roon not responding’. Anybody any thoughts what I could check? All machines are in the same subnet and on both machines I can browse to the ROCK/Data -share .

Are they on the same updates of windows?

Could you describe the machines better, what are they type/make/model, how are they connected to the network and win os version ( found by entering in Winver in search)

Also, any differences in installed software between the two? Anti-virus, for example?

Here are the specs of the machines, hope this helps a bit. I even disabled the anti-virus on Machine B but that didn’t help ;-(

What makes this even stranger is that at first I tried ROON by installing it on Machine A and Machine B was able to connect. Then I moved the ROON from Machine A to my NUC and Machine B gave the connection issue. I even removed and installed the Roon software on machine B.

Machine A : Roon connects to ROCK
os: Windows 10 Pro - version 2004 build 19041.329
Workgroup : MSHOME
Processor : AMD Ryzen 5 3600 6-core 3,6 Ghz
main Storage M.2 ssd 931 GB
Network connection: Gigabit LAN connection
Anti-virus : Bitdefender

Machine B : Roon can not connect to ROCK (it sees ROCK but hangs on connection)
os: Windows 10 10 Pro - 64 bits, versie 1903 - build 18362.900
Workgroup : MSHOME
Processor : Intel Core i7-3770 CPU 3,5 ghz
RAM : 16 GB
main Storage : SSD Samsung 120 GB
Network connection: Gigabit LAN connection
Anti-virus : F-secure

Can you post a screen shot of the login failure or connection failure.

And below a printscreen of the Roon-logfile on the machine that can’t connect:

Just to add another testscenario: I created a new Windows account on the failing Windows machine and installed a fresh version of ROON. Unfortunately, no luck, ROON still hangs and won’t connect. Getting a bit frustated on that end. Anyone other ideas? Can I debug in more detail the ROON logging with regard to the failed EnsuredAuthReady-call?

Have you tried turning off your Firewall and Anti-Virus and on Machine B to see if they might be mixed up in the issue. I noticed that you were using different AV between Machines A and B.

Disabling firewall & anti-virus did not help.

However I think I solved the issue. I enabled both SMB 1.0 and a two additional discovery functions on the Windows machine. At first that didn’t seem to help and then decided to remove the SMB 1.0 feature as I made two changes in one time. After disabling the SMB 1.0 feature all that remained was the automatic (delayed) start of two Function services. It appeared that was the trick; all of sudden the ROON client connected to my ROCK! Just to be sure I turned off the Windows machine and put it on again; ROON was still able to connect to ROCK!

Below a picture of the services I enabled; the top one is set to automatic, the second to automatice delayed.

1 Like

Great to hear and thanks for sharing your solution!