Roon OS woes, build 1.0.221 [resolved]

It’s times like these I’m glad I have a standard sata SSD in my MOCK. What a nightmare to sort out. Well done for mailing it so soon.

Thanks for the quick fix. I’m back up and running

This is what worked for me

"Next steps for those affected


For those running ROCK, you’ll want to download the latest version here and run the recovery function . Note that if you install instead of recover, your database and settings will be lost, so it’s important you choose the correct option.

Option 1: Windows / Mac OS / Linux

  • Plug in your USB flash drive (it must be larger than the factory reset image size – 1GB is more than enough).
  • Download and install Etcher from
  • Start Etcher
  • From the Etcher application interface, select your .img.gz file as “the image”
  • From the Etcher application interface, select your USB flash drive as “the drive”
  • Click on “Flash!”


  • Turn off your NUC.
  • Unplug any USB storage you might have plugged into it. You can plug it back in after your install.
  • Insert the USB flash drive you prepared earlier into the front of the NUC
  • Turn on the NUC and press the F10 key on your keyboard. Continue to hold the F10 key down until you appear at a menu that is asking you which device you’d like to boot from.
  • Select the USB flash drive.
  • Follow the instructions to install Roon OS. This procedure can take a few minutes, depending on the performance of your USB flash drive and the SSD to which you are installing.
  • Once it is done installing, unplug the USB flash drive and hit ENTER to reboot.
  • On next boot, don’t hold F10. Your NUC should boot from the SSD, and a few seconds later, you should see a Roon message displaying the IP address of the NUC. This IP address should be entered in a web browser (on another computer) in order to complete ROCK setup (installing Codecs).
1 Like

A post was split to a new topic: Can’t fix nucleus after 1.0.211

4 posts were split to a new topic: Having trouble booting ROCK installer

A post was split to a new topic: Trouble recovering ROCK

I have recovered Rock with the latest image file, and afterwards I could do the update without losing connection. Thanks for the fast workaround!

This new image works well.

Thank you!

Thanks to Dylan and the Roon team for the fast turnaround on the fix and Rodrigo for these essential detailed steps, I’m also up and running again!

However, I strongly urge that the Roon team acquire a Nucleus that is susceptible to bugs like this for testing of any future software builds. This was not fun. I purposely bought the Nucleus to avoid wonky problems like this and just enjoy music.

Ha! Good luck with that. If you read the analysis report, it is stated that the Roon Labs team did have the same hardware as the 0.4% of Roon users who were struck by this issue - and the Roon Labs team did not see the issue manifest itself on their hardware.

As they say, it is possible that certain SSD manufacturers have changed chips internally on certain of their SSD models…

Why didn’t we test with this hardware that was affected?

We did test it, but our hardware didn’t exhibit this issue. This makes sense given the relative rarity of this issue. In our QA lab, there are devices that match the exact RAM, SSD, and NUC as affected users, and none of them exhibited the issue. Even after receiving reports from users, we were never able to reproduce in-house. It’s hard to say why this is, possibly a revision of the chips, or just slight performance or firmware-version differences between SSDs. It is clear that there are variations even among the same hardware that were affected while others were not.

1 Like

Although I was not impacted by this issue (I have never had any issues with Roon), I did watch it unfold.
All at Roon need to commended for their quick response and hard work.
Roon found a needle in a haystack issue quickly, fixed it, tested it and released the fix within hours.

Well done all at Roon. You all need to give yourselves a pat on the back for an incredible job!


2 posts were split to a new topic: Failing to flash Roon OS image to USB stick

Agreed. Everyone needs to remember that issues are amplified on the forum. I don’t need 100% perfection, just 100% responsiveness and transparency, which the Roon team delivers.


Thanks to the Roon team for first-aid advice but for those of us with a Nucleus, it was disconcerting to have to get under the hood!!


The fact that you only have 5 people on your QA team explains a lot about the horrible quality of your product.

Completely uncalled for post.

What did you accomplish by your display of peevishness?


Name one consumer audio software company that has more QA staff. I encourage you to find out how many dedicated QA staff is involved for Audirvana (which Roon users occasionally compare Roon to). You may be surprised. (Audirvana is another very fine piece of software, despite the limited resources they have).

Roon Labs have indeed offered super quick resolution on this matter and should be commended.

If you want a 50-person QA team, are you willing to pay 10 times the subscription price?


After recovery when error first occurred, all was ok with the exception of my “Recent” section, it was empty… I downloaded the latest ROCK just now and executed a new recovery. After successful recovery I was prompted to update ROCK. I did that. All is well again. Thank you for your kind attention.

I understand that these things can happen and appreciate the clear guidance to the fix. However, I think it would have been nice to see some hint of an apology - I had not intended to spend my Sunday fixing a broken Roon Server


3 posts were split to a new topic: Never got to try Roon due to 1.0.221