Roon Server Migration issue - iMac to sonicTransporter i5

I’m having a problem trying to change my Roon Core from an iMac to a sonicTransporter i5 RoonServer.

Everything looks like it will work fine, but when I try to add a networked storage location on my Synology NAS I get the “operation now in progress” message and none of the music is loaded. I hear the NAS trying to read data, but no albums are added to my library.

I’ve tried using folders with only a few albums in them, and again, the NAS is pinged constantly, but no albums are added.

I’ve tried all the suggestions in several other posts about migrating to the sonicTranporter, and rebooted several times, but nothing seems to work. My Tidal Library loads and plays fine.

Hi @John_White

I think you were trying to contact Support. Let’s drop a flag for @Support and they should be in touch soon.

How of I “drop a flag for @Support” ?

Hi John,

We’ve been using the phrase “drop a flag” for someone for a while now. It can be misleading since a person can flag a post for moderation, if there’s an issue with the post.

If you want someone to be notified about a post, you can click Reply on the persons post or type @John_White, for example, and they will be notified.

Cheers, Greg

I may be dense, but I still don’t get where I type @support

You just did it. Anywhere in your message is fine.

Cheers, Greg

Hi @John_White ---- Thank you for the report and my apologies for the troubles. I would to gather the following information from you to help aide in my evaluation of this issue you are experiencing. Please see below. Thanks!

  1. I see you’ve started to describe some of the details of your setup :clap: May I kindly ask you to please expand and elaborate a bit further on this information as seen here.

  2. Can you confirm how you are trying to mount the NAS in roon? Are you able to provide me an example of what the path looks like?

  3. Are you able to access the NAS using the same path via “Connect to server” found under “Go” in the finder?


Eric, Thank you for your support. Here are the details you request:

Roon version 1.2 (build 161) stable (64 bit)
OS X Yosemite version 10.10.5
Roon Core running on IMac (27-inch, Late 2013)
3.2 GHz Intel Core I5
24 GB memory 1600 MHz DDR3
Music Storage is on a Synology DiskStation DS1812+
120,000 Total Tracks (30,000 Tidal, 80,000 16 bit Flac, 10,000 24 bit Flac)

Network is 5 music zones all with Ethernet Cat 5 Connectivity - The modem is from Verizon Fios - Actiontec Wireless Broadband Gigabit MI424WR installed approximately 2 years ago
I use many digital switches and wireless access points
I use only Ethernet wired connections for my music system with the exception of wireless remote control from iPhone and ipad.
My network is mostly PC based with many computers, some used as Roon endpoints.

I have used this 5 zone music network for over 10 years without ever experiencing a significant problem beginning with a Yamaha MusicCast system circa 2005 gradually migrating through Sonos, Squeezebox, JRiver. Now that Roon has implemented RAAT I run everything exclusively on Roon. I have maintained redundacy with Sonos and JRiver.

The system runs flawless as configured, and always has run flawlessly.

The only problem is when I tried to migrate from my IMac Roon Server setup to a sonicTransporter I5 that I just purchased on Thursday. I have tried to make this migration 3 times.

First, I followed Accessing the Roon Database on your sonicTransporter instructions. When instructed to “1.Go into Roon and delete your watched folders”, I disabled all watched folders. Everything appeared to be going as planned. The last step was to “9.Add in your watched folders.” I used paths in the format smb://diskstation/all music files with username and password specified which were identical to the format used on Roon Server for about 18 months now. I also tried including and not including a workgroup name, since it said “if required”. I also tried different usernames and passwords that I verified worked with all my other applications (including Roon) as well as in the “via “Connect to server” found under “Go” in the finder”. Finally, I changed permissions on the Synology NAS to allow “guest” to read and write. In all cases I get the “operation now in progress” message and none of the music is loaded. My Tidal library is loaded and works fine. When I look at the log files there are thousands of mount failures.

I tried a clean install on my second attempt. Since I suspected the mount failures were related to all the information transferred from roon database I decided to install Roon without transferring the roon database. I followed the directions above (4.Delete all the files in the RoonServerDB folder), but skipped the step “5.Copy the Roon Database files over from your computer”. I was willing to give up all my history etc. to get the thing running. When I added watch folders the exact same thing happened.

My third and final attempt was to try to move my Roon Database again. First I used “Library Maintenance” to “Clean Up Library”. I cleaned up deleted tracks and tracks that are not associated with a storage location. I did not clean up tracks that are associated with disabled storage locations, since I wanted to be able to move back to Roon Server on my IMac easily, which I’ve now done three times so I can listen to music. I followed the instruction “1.Go into Roon and delete your watched folders” by “removing” the watched folders rather than “disabling” the watched folders. In doing this I discovered that I could not remove the default “/Users/username/music” in Roon, I could only disable it. I removed all the other watched folders. I went through the same nine step process as instructed.

On my third attempt I have the same problems mounting my music files. I simplified the process by only adding a single watched folder (I also tried this on my first and second attempts). In the log I can see attempted mounts of the default “/Users/username/music” folder that was disabled but not removed because that was not an option. The log also showed thousands of mount attempts on the folder I specified as a watched folder.

At this point I am extremely frustrated and regretting my decision to purchase the sonicTransporter I5.

Hi @Eric and @agillis

I thought it may be helpful to copy Andrew on this post, since I purchased the sonciTransporter I5 from Andrew as well as 2 microRendus and a Sonicorbiter SE. He clearly has the most expertise and I assume he provides support for the products he sells.

Thank you in advance for you support.

Hi @John_White ---- Thank you for the follow up and the very thorough report . Your diligence is appreciated!

Are you able to confirm that you can access the NAS across your network via the “connect to server” feature found under “Go”, in the finder on your MAC?



Yes, as I indicated in my “very thorough report,”

I also tried different usernames and passwords that I verified worked with all my other applications (including Roon) as well as in the “via “Connect to server” found under “Go” in the finder”.

Hey @John_White – can you try connecting to the NAS using an ip address?

Meaning, for example, use smb:// instead of smb://diskstation. You’ll need to check your router or Synology DSM to confirm the correct IP address.

If you’re unsure about user names and passwords, using Finder as @Eric mentioned is a good way to confirm things are working independent of the SonicTransporter/Roon.

Let us know how it goes, and we’ll figure out what going on here.

Thanks @mike
That worked without a hitch. Also, I use a permanent IP address for my DAC, so I won’t have to worry about that changing and re-specifying the ip address in the future…

Thanks @John_White It can be a bit trick to mount a NAS into Roon. As you have seen you need to get the syntax exactly right. It’s best to let Roon support this since they have the best documentation on how to do it.

Good to hear you have it working.