Roon Server Setup Issue on Different Subnet


I’m a new Roon user trying to get it up and running, but I’ve encountered a few issues that I’m hoping the community may be able to help with.

I’ve installed Roon Server on my Synology NAS. Unfortunately, my NAS is on separate subnet (192.168.1.xx) then all my other devices (other devices are on From reading the forums the past two days it is clear this is not the ideal setup but it is the best option I have since I don’t have another computer that is always on.

I’ve installed the Roon Remote on my phone and my computer and tried to access the Roon Core on my NAS. Unfortunately, both devices are unable to find the core and continue to spin. I’ve removed all firewall restrictions between the two subnets. I’ve explicity re-broadcast UDP and TCP traffics on port 9003 and 9100-9200 (as suggested in other posts) across both subnets. Nothing has helped.

Is there something else I can do? Is there something I’m missing? Any help provided would be greatly appreciated.


[Edit] Also tried explicitly giving the IP address of the NAS when the remote was looking for the server


You have given the answer in your post: you have two different subnets in your home network. The Roon Core must be in the same subnet as all other Roon devices. See here.


Hello @stongelidis,

As @Geoff_Coupe mentioned, we do not support Roon running on different subnets since our multicast protocols used for discovery only work on one subnet. You can read more about this discussion in the following threads:


Thanks; I was hoping there was a workaround that I just hadn’t found yet.

I was recently working on a Sooloos system that required a separate subnet in a residence with tons of devices. It had so many issues when it was on the main network. The beauty of Sooloos is that I could tell the remotes what the IP address of the core is. Then they worked perfect.

Does Roon have any plans to enable this feature that they had with Sooloos way back in the day?

Follow up: I have it working now because I entered the IP address but it wasn’t working last night. I’m worried this isn’t a good solution based on my experience and this other thread - Question about Multi-Vlan limitations while using Roon