Roon Web Controller 2.0.0 ALPHA now available

Hi Mike,

Just installed the Dockers version and working beautifully

To Add to Readme.md for issues

(1) Issue with Profiles - when having multiple profiles in ROON on login it defaults to the first which then presents the wrong playlist selection and tags. Please can we have ‘save’ Profile or make Primary/ Default Profile (tickbox in settings)

Small request if possible - A Clear Queue Button on Queue Toolbar

Great product

Thanks

Mark

Hi how do I install docker version? All other dockers I have used I just enter the pull command but this one seems to be private, I had to sign up to docker to get to it, and on my machine when I put that pull command in, it fails

Hi @Gareth_Irwin if you could copy and past the output of the Docker pull/run commands it will help people to help you. If you can post them here I’ll try to help.

Hi here is the output:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name=‘roonweb’ --net=‘host’ -e TZ=“Europe/London” -e HOST_OS=“Unraid” ‘roon-web-controller’

Unable to find image ‘roon-web-controller:latest’ locally
/usr/bin/docker: Error response from daemon: pull access denied for roon-web-controller, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.
See ‘/usr/bin/docker run --help’.

The command failed.

As I say I have never been asked to sign up to docker before, it would appear to be a private docker rather than public and clearly from the output this is why its failing?

So Docker Hub images have two part names to identify the owner and image name. Use “pluggemi/roon-web-controller” instead of just “roon-web-controller” and it should work.

So

docker run -d --name=‘roonweb’ --net=‘host’ -e TZ=“Europe/London” -e HOST_OS=“Unraid” ‘pluggemi/roon-web-controller’

instead.

Good luck,
Carl

Hi here is the output for that:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name=‘roonweb’ --net=‘host’ -e TZ=“Europe/London” -e HOST_OS=“Unraid” ‘pluggemi/roon-web-controller’

Unable to find image ‘pluggemi/roon-web-controller:latest’ locally
/usr/bin/docker: Error response from daemon: manifest for pluggemi/roon-web-controller:latest not found: manifest unknown: manifest unknown.
See ‘/usr/bin/docker run --help’.

The command failed.

I just tried another docker same result evidently this is something to do with Unraid which I need to learn, sorry to have bothered you

The web-controller doesn’t have a tag called latest, there is only an alpha tag. You have to supply the tag in the command, so the full image name at the end of the run command should be:

pluggemi/roon-web-controller:alpha
1 Like

Hi Thanks.

Sadly after a bit of digging it would appear unraid does not have docker compose so has no idea what I am on about. I have only installed dockers from their app section (such as roon server) but evdiently they are pre built.

Please also note that the docker image is only built for an x86_64 processor, so it is not likely to work on a NAS device.

Please read the README on the docker hub link: Docker Hub

Or the README on the github link: GitHub - pluggemi/roon-web-controller at alpha

Please also note that you will have to specify the IP address of your Roon server and when you do, --net=‘host’ is not required.

Docker compose is not required. This can be run with a standard docker command, as noted in the README.

The image name is:

pluggemi/roon-web-controller:alpha

Is there a way already to install Roon Web Controller 2.0.0 with the Roon Extension Manager?

The installation of Roon Web Controller 2.0.0 was easier than I thought on my Synology Diskstation. I just downloaded the docker image “pluggemi-roon-web-controller1” within the Synology Docker on my Diskstation (Docker → Registry → Insert Keywords → “pluggemi” → download → launch). In “Details” → “Portsettings” → “Local Port” you see the port the image is using for the browser. In my case 49153.
Really great job Mike!

  1. The docker image runs really smooth. Now for 15 days without any issue. In comparison the “Roon-extension-manager” restarts unexpectedly at least once a day.
  2. I love the new touch concept, much better than the old to use on my raspberry with small touch displays (2.8’’ and 4.0’’) .

The only two wish I have are:

  1. that the settings will be stored in future. Every time I reboot the raspberry the settings are back to default.
  2. A screensaver (when nothing is playing) that displays the clock, so that my raspberry displays are looking like a clock, when nothing is playing.

Again an amazing job, please go on!

Is the project “Roon Web Controller 2.0.0 Alpha” dead?

First announcement here in the forum was June 2020, last answer from Mike Plugge was March 2021. Last change on Github was September 2020.
Really a pity, that nothing seems to move forward. I really was looking forward to the Roon Web Controller 2.0.0 Betta release :frowning:

Yes, the project is effectively dead. Both the beta and the previous release.

Between a new job with long hours, lots of house maintenance, and life in general, I haven’t had time to look at the code for months. And quite frankly, I no longer have the desire to work on it.

Anyone is free to pick up where I left off. The backend code in particular is nearly production ready.

4 Likes

Hi @Mike_Plugge,

Thanks for making clear that the Web Controller is no longer maintained. It is really a pity that this happens to such a popular extension, but a big thanks for providing it in the first place (still using 1.2 on a daily basis :slight_smile: )

1 Like

Thanks for the work you’ve done on the plug-in Mike, I’m enjoying it every day!

1 Like

I am glad to hear from you and I am happy that your health is not the reason for your absence.
Nevertheless, it is an extreme pity that you stopped the development. I was looking forward to the new release, the 2.0.0 alpha I tested is unbelievable much better than the 1.2.0 version.
Can you give us a rough estimation, how many development hours are still missing to get to final 2.0.0?

Also many thanks from me for the plugin, Mike. Using the 2.0.0 alpha version every day.

Hoping there is a person who can take over your work. My programming skills are to little, I am afraid…

Too bad that Mike_Plugge stopped development shortly before completion. I use Roon Web Controller 2.0.0. ALPHA almost daily and it is really great!
The only thing I miss is that the settings (e.g. last selected zone) are not saved and you have to click through them again and again, when you open the link.
I hope that someone continues with the development. That would be really great! I would very much welcome and support also financially.

It is really a pity that the project has been discontinued. I find it very helpful to see directly at my active speakers (1) what is played (2) to make simple changes. And not having to search for my iPhone or iPad every time.
I use several Raspberry Pi’s with 4’’ touch displays. I start the Chromium browser in kiosk mode. I found out that you can jump directly to the right page with “192.168.xxx.yyy:8080/#/touchscreen/now_playing”.

Questions:
(1) What command (Java?), can I use to select the zone automatically? So that I don’t have to select the zone by manual touch every time I start my Raspberry Pi?
(2) Unfortunately the browser does not remember the last settings. Or is there a way to save the browser settings and recall them when restarting the Raspberry?