Roon Web Controller 2.0.0 ALPHA now available

Is there a route for us to highlight these limited features in the api to roon, via github or other method perhaps?

I can’t speak for Roon. Possibly a feature request style issue on github, but I am not sure…

That is the repository I found yesterday but wasn’t sure if that is the one you are using.

It didn’t specify, no feature requests, but looking at the existing issues list and the last release ‘Sep 28, 2018’ I think we have more chance of winning the lottery :grinning:

@Mike_Plugge Sorry for the ignorance but I cannot find this on the README, am I supposed to install this locally or on the Roon Core server? I assumed the later ?

Figured it out and up and running in few minutes.

Excellent work, I have no idea why Roon haven’t done this themselves it’s an utter joke.


Do you have a feature/bug report channel for this project? I see it isn’t enabled on Github.

I specifically wanted to add Signal path, file quality/codec information on the UI. Currently it’s the only thing I keep needing to refer back to my phone.

Would love to see the full MQA path like in the mobile UI!

1 Like

This can be installed anywhere with network connectivity to the Roon Core. It is typically easier to install it on the same box as the Roon core, though.

As for your request, neither signal path nor file type/codec is available in the Roon API, so I can not add it to the the UI. This is a common request, but it just isn’t possible with the current state of the API.


I tried the supplied ‘docker run’ command, but it exits immediately.

bensonmargulies@puck roon-web-controller % docker run -d \
  -p 8080:8080 \
  -e ROON_HOST="localhost" \
bensonmargulies@puck roon-web-controller %

bensonmargulies@puck roon-web-controller % docker ps
CONTAINER ID        IMAGE               COMMAND             CREATED             STATUS              PORTS               NAMES
bensonmargulies@puck roon-web-controller %

Leaving out the ROON_HOST setting works better.

However, while 9090 reports ‘live’, Roon does not see the extension in the setting, and 8080 says that the extension has not been approved.

setting ROON_HOST=MyHostName

does the job, unlike ROON_HOST=localhost.

In Chrome for Android, the silly ‘look this work up in the dictionary’ popups appear for every touch on the screen.

This extension is working great for me!
As I am lazy by nature, if there could be a default setting for the zone, that would be awesome.

I have multiple zones and only use it for one of them. Having the ability to select one of them by default would be good. I noticed I can bypass the ‘touchscreen question’ by going straight to /#/touchscreen .
If there is something similar possible for a source, that might be the easiest/best way.

Regardless, @Mike_Plugge thanks for putting the work in for this nice extension!

Hi Mike,

Just installed the Dockers version and working beautifully

To Add to for issues

(1) Issue with Profiles - when having multiple profiles in ROON on login it defaults to the first which then presents the wrong playlist selection and tags. Please can we have ‘save’ Profile or make Primary/ Default Profile (tickbox in settings)

Small request if possible - A Clear Queue Button on Queue Toolbar

Great product



Hi how do I install docker version? All other dockers I have used I just enter the pull command but this one seems to be private, I had to sign up to docker to get to it, and on my machine when I put that pull command in, it fails

Hi @Gareth_Irwin if you could copy and past the output of the Docker pull/run commands it will help people to help you. If you can post them here I’ll try to help.

Hi here is the output:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name=‘roonweb’ --net=‘host’ -e TZ=“Europe/London” -e HOST_OS=“Unraid” ‘roon-web-controller’

Unable to find image ‘roon-web-controller:latest’ locally
/usr/bin/docker: Error response from daemon: pull access denied for roon-web-controller, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.
See ‘/usr/bin/docker run --help’.

The command failed.

As I say I have never been asked to sign up to docker before, it would appear to be a private docker rather than public and clearly from the output this is why its failing?

So Docker Hub images have two part names to identify the owner and image name. Use “pluggemi/roon-web-controller” instead of just “roon-web-controller” and it should work.


docker run -d --name=‘roonweb’ --net=‘host’ -e TZ=“Europe/London” -e HOST_OS=“Unraid” ‘pluggemi/roon-web-controller’


Good luck,

Hi here is the output for that:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name=‘roonweb’ --net=‘host’ -e TZ=“Europe/London” -e HOST_OS=“Unraid” ‘pluggemi/roon-web-controller’

Unable to find image ‘pluggemi/roon-web-controller:latest’ locally
/usr/bin/docker: Error response from daemon: manifest for pluggemi/roon-web-controller:latest not found: manifest unknown: manifest unknown.
See ‘/usr/bin/docker run --help’.

The command failed.

I just tried another docker same result evidently this is something to do with Unraid which I need to learn, sorry to have bothered you

The web-controller doesn’t have a tag called latest, there is only an alpha tag. You have to supply the tag in the command, so the full image name at the end of the run command should be:

1 Like

Hi Thanks.

Sadly after a bit of digging it would appear unraid does not have docker compose so has no idea what I am on about. I have only installed dockers from their app section (such as roon server) but evdiently they are pre built.

Please also note that the docker image is only built for an x86_64 processor, so it is not likely to work on a NAS device.

Please read the README on the docker hub link: Docker Hub

Or the README on the github link: GitHub - pluggemi/roon-web-controller at alpha

Please also note that you will have to specify the IP address of your Roon server and when you do, --net=‘host’ is not required.

Docker compose is not required. This can be run with a standard docker command, as noted in the README.

The image name is:


Is there a way already to install Roon Web Controller 2.0.0 with the Roon Extension Manager?