RoPiee and HiFiBerry Amp2

First of all - thank you SO MUCH for making such an easy to use image. I was hesitant to give Raspberry Pi a go for creating some different zones in my house, but with RoPiee it has been roughly 1000 times easier than expected. So thank you!

I do have a question about settings however. I have had three Pi’s running smoothly in various configurations. Today I added a fourth - in combination with a HiFiBerry Amp2 HAT. When I configured RoPiee, the Amp2 was not a selectable option under the HAT dropdown menu. I tried going with the Amp/Amp+ option, but Roon didn’t see it. So then I tried the HiFiBerry DAC option, and Roon did pick it up. So is this the best option to go with? I’m asking as the only option I am being given for volume control with this setup is DSP. I don’t know if this is good or bad, but I am getting the green “High Quality” path rather than the purple-ish Lossless path - and all three of the other zones I have set up with RoPiee are giving me the Lossless path.

Incidentally, the other three zones are:

  • HiFiBerry Digi+ Pro
  • Audioquest DragonFly Black (so no HAT)
  • NAD D 3020 (so again, no HAT)

Any advice or suggestions (or just telling me that I’ve got it set up as good as can be) are much appreciated.


I had the same problem, but you need to set it up as a DAC+ I believe.

Here is a thread on this problem.


Yeah you need to select the DAC+ from the menu.
Last time I promised to add it to the menu anyhow (and select the DAC+ out of sight), but I didn’t follow that one up.

I’m working on a (small) update and add this.


Thanks @Andrew_Callum and @spockfish for your help. For whatever reason Roon will not pick it up when I switch the HAT to DAC+. It only picks it up when I use DAC. I guess I’ll sit tight for the update. Thanks!