Ropieee can't use Realtek RTL8812AU after last update (3.066 stable)

Hello !

Since the last Ropieee update my WiFi USB Realtek RTL8812AU-based chipset (Asus USB-AC56) are not working anymore. I have two of them and I can clearly see the device is in lsusb:

**Bus 001 Device 004: ID 0b05:17d2 ASUSTek Computer, Inc. USB-AC56 802.11a/b/g/n/ac Wireless Adapter [Realtek RTL8812AU]** 

However there is no wifi interface in ‘iwconfig’ and therefore, no possible to configure it in Ropieee WebUI. The kernel module seems to not load properly.

I have tried to re-install Ropieee
I have tried to plug the USB dongle on other Ropieees (no interface found)
I have tried other dongles on this Ropieee (it works)
I have tried this dongle in a computer and that works - not a dongle issue
I have send feedback under the ID 53555404b1929934
I could not rebuild the kernel module from source as I’m missing the kernel headers

Anyone else experiencing the same and have you a solution / recommendation for me?

Thank you all

Unfortunately there is no ‘quick’ solution other then using either a different dongle or go for an wifi-2-ethernet bridge adapter.

The state of Realtek drivers is pretty much a mess on linux. RoPieee uses a set of Realtek drivers that matches the 3 test devices I own. This however means that other devices are pretty much a ‘guess’: they can work (and obviously they did for you), but there’s no guarantee.


Thank you @spockfish - I had selected those because of their amazing range, external antenna, and after I saw in the v374 Ropieee release notes " * NEW: support for USB WiFi dongles based on the Realtek RTL8812AU chipset".

I can probably make them work using a newer version of the kernel module; I have to build it from source, do you have by any chance the linux headers that I can use for kernel version 5.4.83-1-SPCKFSH-v7+ ?

I understand this will be temporary but if it hopefully works, the changes can be merged to the main Ropieee branch in the future.

Thank you

RoPieee does support the RTL8812AU chipset. However, there are multiple drivers out there that provide support for it, but they do support a different set of hardware. And then there’s overlap :exploding_head:

With the current drivers there is support for the 3 hardware devices I have in my possession which means I can guarantee support for them up to a reasonable level.

I don’t have a ready to go linux header package for you as it is not the intention of RoPieee that users build stuff themselves.



I don’t know what has changed nor when, but happy to report that ASUS USB-AC56 (using RTL8812AU) is working again using Ropieee version 4.002.

It might have worked in earlier releases but it definitely stopped working for me in Feb 2021 in Ropieee 3.066 when I opened this thread, and I randomly tried this weekend and to my surprise it is now working again with 4.002.

Thank you !

1 Like

Hi @Emmanuel_Tychon - can I just check this is still working ok for you? Don’t suppose you’ve tried it on the Ropieee-NG beta yet? Thanks!

Hello @dhusky - I have not tried the beta yet. I’m forcing myself to not upgrade Ropieee anymore: it it works, don’t touch it!

Are you asking because you are missing support for RTL8812AU on the beta and it was working before?

Wise words!

Nope, just asking as was thinking of buying the Asus dongle! Thanks.

@dhusky I have just tried for you on Ropieee NG-BETA 2021.11.11 (262) [beta] and the ASUS USB-AC56 (using RTL8812AU) is working fine.

1 Like

That’s very kind of you @Emmanuel_Tychon thanks - I’ll give it a go for my use case - if that doesn’t work I’ll have to cave and put a cable in.

In case it’s of help to others, I can also confirm this adapter works well, so far at least.

In an area with poor signal (signal level 41/100), I’ve gone from a flakey connection (Archer T2u Nano) at standard 44/16 to seemingly being able to stream DSD256 solidly (if I wanted). It’s very large and hideously ugly but can potentially be tucked away out of sight. Sure a cable would be a better bet but for now I’m hopeful this might do the trick.