Ropieee zones disappearing after Roon update

Hi @spockfish

I have three Rpi4 RopieeeXL boxes (two bare bones, one Pi2AES). They’ve been running flawlessly for probably a year now. As of this evening, just following my Roon core and app update, they no longer are visible as zones. If I go into settings / audio, they do appear sometimes, either with the blank name box and ”Enabling…” in red, or with the correct name and the purple “Enable” button. But then no matter whether I try and interact or not, within a few seconds they disappear (no longer appear as rows / boxes in the Audio menu). After that they no longer appear at all unless I kill the Roon remote on iOS and restart it. In which case the whole loop starts again. I’ve tried to reboot, reinstall Roon Bridhe (using the yellow button at the bottom of the Advanced tab in Ropieee), all to no avail. For what it’s worth, the RopieeeXL are all still visible to Spotify and work fine if I start the zones from the Spotify app.

Please help, I’m confused - and want to listen to music! Not sure if something went wrong with the new Roon build?


And actually, since this seems relevant, if I go to Settings / About in the Roon remote, I do see all three RopieeeXLs listed as Roon Bridges, and all three say “You have the latest version installed”. And then I go back to Settings / Audio and all I can see are my Sonos zones.

I have two RPi4’s running RoPieeeXL and both were working. However, as a result of your post, I checked and they were waiting to do an update, so I updated both to build 880 and both are working fine.

It might have more to do with your end-point. I am running Meridian Prime with one and Dragonfly Cobalt with the other.

Thanks Jim. Glad working for you!

Fwiw, I tried unplugging two of them, and I still get the same “flapping” behavior where the one remaining Ropieee appears in the Audio tab, disappears, reappears, then disappears for good.

@spockfish if you want the Feedback file it’s at 0d593e98c0d04cd6


John, sometimes it is helpful to reboot your core and then reboot all of your RoPieee devices. After, make sure that none of the extensions need to be enabled – one of my displays tonight needed these steps.

EDIT: just read your last post. I’d also suggest re-saving your RoPieee configuration.

Thanks. Well, now after stopping and restarting the docker container where Rock is running, and rebooting each of the Ropieee’s, I now can see them in Settings / Audio, and they appear to be engaged. But bizarrely, they are still not visible in the list of zones when I click on the icon to choose a zone. I’m beginning to suspect it’s something to do with the new Roon build.

You can see that one of my Ropieee is associated with a zone called Bifrost Jotunheim, but there is no zone with that name in the zone picker.

Ugh… still “flapping” - if you watch Settings / Audio for a few seconds, those 3 Ropieee zones disappear. I’m going to bed.

You don’t see the zones named for the DAC they are connected to? For instance, the RPi4 I am using at the moment shows up as “Meridian Prime.”

See above. They appear in the Settings/Audio list but then disappear. Even when they are in that list, they are not in the “zone picker”. Similar behavior after rebooting ROCK container, Ropieees.

And if you want something else strange… at times when the Ropieee are flapping (appearing and disappearing), sometimes I see two of the same zone (see below):

I am hoping that the feedback / logs will indicate a possible source of your problem. @spockfish may have time to take a look for you.

I am a bit perplexed by the flapping – usually this means some basic network issues (broken arp entries and whatnot). I assume from your use of Docker and edited screenshots that you have some sys admin experience, so I won’t suggest the common troubleshooting steps because you likely have already done all of those things (reboot from the core outwards, flush the arp / dns, check for bad cables / ports, clear DHCP, and so forth). I’ll be interested to learn what the problem is/was.

Super strange. It’s not a Ropieee issue, but a Roon issue where there are 7 maximum Sonos zones and when you hit that cap, the rest of the Sonos zones plus all Ropieee (and I assume other Roon Bridges) don’t show up. Temporary fix is to disable a few Sonos zones to get under the 7-Sonos cap.

Big thanks to folks who diagnosed it… @Eamonn_Maher @Mr_Smys

1 Like