[SOLVED: replaced faulty Flirc] Flirc + Ropieee stopped working after recent Ropieee update

Ropiee does detect Flirc:

The extension is enabled.

image

Removed and added the extension, rebooted both RoonSever and Ropieee, but doesn’t respond to the remote. The remote itself appears to be fine because it is controlling my DAC. Any ideas?

Did you send feedback in to Harry on this? Might help him take a look.

Has the problem been resolved?
I’m also using FLIRC and haven’t updated to 2023.01 yet for this reason.

Just tried it for myself with a new install on a blank SD Card.
No problems here, FLIRC remote works just fine with release 2023.01 (710) on a Pi3B with AlloDigiOne HAT.
Great Job, Harry!

@hacker19 Just for thoroughness, did you check the battery in your remote?

Remote batteries are fine, I tried new ones as well. Remote is able to control other devices, so I think its ok. I suspect the problem may be with the Flirc’s IR receiver. Will buy a new one.

Thanks for confirming. I suspect the problem may be with my Flirc’s IR receiver so I’m going to buy a new one.

Have you tried to connect the FLIRC receiver to your PC and access it via the latest release of the FLIRC software?
There has been a firmware update in September 2022 which can be installed using the latest software version available on the FLIRC website.
Also while connected to the PC you can try to relearn the IR commands of your remote and this way see, if the receiver still works.
Maybe worth a shot.
Good luck!

Just as I suspected, the Flirc has gone bad. The replacement is working fine.

2 Likes