Starlink (ISP) with ARC: CG-NAT Requires VPN Workaround (See Staff Post)

I recently got ARC to work with Starlink by using a third party VPN service that provides port forwarding. I haven’t messed with it much yet but hope to test it more over the next few days - I’m not too sure how much support ROON will be able (or want) to provide, but at lease Conner mentioned above it was cool to mess with ‘VPN solutions’


Hi @Peter_Gallagher,

Thanks for the update and my apologies for the delayed acknowledgment here. I appreciate you keeping us posted on the workaround you’ve been able to work out.

To clarify where we stand for other users with Starlink who are encountering their blanket carrier-grade NAT:

At this time, Roon ARC requires an external (WAN) IPv4 address. Similarly, Roon requires the Core to have an address in the IPv4 format, as Roon doesn’t support IPv6 at this time. For networks that have implemented a layer of network address translation at the ISP-level (aka carrier-grade NAT, CG-NAT), your router will generally have an IPv6 address or a dynamically assigned IPv4 address within a range. The latter case (dynamic IPv4) sometimes allows for port forwarding via the configurations we’ve designed for ARC. Dedicated or dynamic IPv6 configurations will not work with ARC. Starlink has fully implemented IPv6 for their residential-tier accounts, at least in cases we’ve encounter here on Roon Community.

Rest assured that port forwarding with IPv4 support is only the initial implementation of Roon ARC, and we are actively researching several workarounds that will hopefully allow for more of our users to access the mobile streaming features offered through ARC as part of Roon 2.0. At this time, however, offline download playback or home Wi-Fi use will be the limits of ARC use for users with IPv6-assigned Starlink accounts.

That said, there are several VPN and proxy-server solutions in the #roon and #tinkering sections that users have configured as workarounds. @Peter_Gallagher has mentioned one above. Common solutions include NordVPN or other common VPNs, and Tailscale. Note that the support team will be unable to assist with VPN configuration, but we can help guide you to popular threads with solutions other users have found for their own use cases.

Roon Core Machine

Roon Core running on Innuos Zen Mini on local network ip

Networking Gear & Setup Details

Starlink Gen 2 Router in Bridge Mode with TPLink Archer 200 connected by Ethernet acting as router. Core is connected to TPLink WPA8631P PoE adapter via Ethernet

Connected Audio Devices


Number of Tracks in Library


Description of Issue

Roon ARC Test result
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

MultipleNatFound. seems to be issued by Starlink, with my the TPLink MR600 router issuing

I’ve not had doubleNAT issues with tools such as RemotePC, so this is the first time I’ve had double NAT issues.

I don’t believe Starlink can provide their customers a static ip, so can you recommend any other solutions for ARC to be able to see my core?

Starlink is CGNAT, nothing you can do without implementing a VPN or upgrading to the business service.

1 Like

Hi @Rich_Beattie,

Unfortunately, you’re correct that the blanket IPv6 implementation with Starlink is unnavigable with the current port forwarding configuration of ARC. Please see the staff post here. We’re working on possible solutions to democratize access to mobile streaming for our Starlink users, but at this time, you’ll have to pursue VPN options like those mentioned here:

Starlink (ISP) with ARC - IPv6 Won’t Allow Port Forwarding: VPN Workarounds

Starlink compatibility for Roon ARC?

or here:
VPN: step-by-step

This situation, very very likely, holds true for T-Mobile 5G Home Internet as well. The same solution you implement for Starlink may very well positively impact T-Mobile’s service as well.

1 Like

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details


Connected Audio Devices

iPhone 13
Linn Selekt

Number of Tracks in Library


Description of Issue

Tried ARC today and worked very well on Wi-Fi. Tried it via 4G and all I got was a red box with Poor Connection written in. Had full 4G.


I’m still getting it. Have not yet managed any form of non Wi-Fi connection.

I’m not sure if this is relevant.

However I did discover that Starlink blocks all inbound ports and cannot be configured otherwise.

Does anyone have an answer for this?

Hi @Marcus_Adams1,

Thank you for your heroic display of patience while the support team worked to get through the queue of ARC-related threads after launch.

I’m noting your internet service provider is Starlink. Unfortunately, the port forwarding that supports mobile playback via ARC in Roon 2.0 can’t navigate the carrier-grade network address translation implemented by that provider. However, there are workarounds available. I’m going to merge your initial post into a thread where Starlink users have been posting solutions momentarily.

Seems to be unusable with Starlink.

@Marcus_Adams1, Starlink uses CG-NAT which prevents ARC from working over the Starlink network.

Unfortunately true. It effectively reverts to being as it always has been.

Sadly, where we live there are no other realistic internet services.

I’m in the same boat. I truly love Starlink compared to every other option I have tried in the middle of nowhere. Too bad Roon can’t devote the resources to solve it…I’m sure we are a very small subset of users in this situation. On the plus side we now have a crazy slow search in Roon with, from where I stand, even worse results. :clap: :clap: :clap:

Also a Starlink subscriber and ran into the same issue. It took a while to figure out that the issue was related to Starlink: Help needed to resolve: “doaction request return statuscode: UnknownError” - Support / Port Forwarding Help - Roon Labs Community

Like several Starlink users, I’ve been successful using ARC with a VPN - Recently however, Starlink has rolled out IPv6 in our region -

Should ARC be configurable without a VPN for Starlink customers where IPv6 has been implemented? I messed with a bit today but was unsuccessful …Is a static IP necessary for IPv6?

thanks - !

Roon arc does not do.ipv6 at the moment.

1 Like

that explains that then- thanks!