Synology Firewall blocks ChromeCast Devices and access

I am using a Synology DS 920+ running my roon core. There was an update a few days ago which changed the situation a bit.

Before the update I was running the core with the firewall turned on on my Synology. I was able to connect my core using my Windows 10 PC / iPhone / iPad. The strange part was, that i weren’t able to “see” my ChromeCast-Ready Speakers.

Then the update appeared and i did update my core and all my devices.

Afterwards I was not possible anymore to connect my core with any of the devices.

I struggled a bit and after searching for a while I turned off my firewall on my synology. Then my devices were able to connect my core again and I even saw my CC devices. (I probabely didn’t saw them in the beginning because of my firewall.)

But if I am turning on my firewall again (and the port rules are activated for roon!) my devices aren’t able to detect the core again!

How can i use roon, while my firewall is turned on on my Synology NAS?

I am not sure, if you refer to your chrome cast devices here. I just did a google search and chrome cast seems to use the following ports:

Chromecast uses the following ports: TCP 8008 and 8009 and. UDP 32768 through 61000.

I only added the Roon specific ports as a template to the Synology firewalll (from what I could find here in the community board and knowledge base). Please try to add the chrome cast ports manually as well…

Thanks for the response! I will try it this evening and report if its working.

Is there a know how which ports have to be opend, that the divices can detect the core even when the firewall is turned on?

By the way I already opened those ports mentioned in this thread:

It’s no longer 2015 - the information from that post is now partly outdated. It seems that Roon Labs is reluctant to give users the same level of information they gave back then and instead seem to have resorted to sharing the following non-relevant information:

So sadly, there is no current information from Roon Labs about ports (port ranges) that need to be open - despite several users asking for it.

@crieke Is there no option, because i want to activate my Synology Firewall for safety reasons! And right now i can’t activate my firewall because otherwise roon is not working