Testing IPv6 support in Roon (for users locked out of ARC due to ISP reliance on IPv6 or CGNAT)

The ISP is Rogers in Canada. Using eero mesh. Unable to make ARC work till the recent Roon fix. Followed the ARC update instructions and successful first try.

1 Like

What were the instructions?


All you likely need is the following extract from Roon’s email of March 9 email with the same title as this thread. If needed, the full explanation is there as well,

" ### Notes on IPv6

  • IPv6 has been enabled for all cores running Early Access. To ensure that support is enabled on your core you will need to restart Roon or Roon Server twice (once to update the configuration and again to ensure that the new networking code runs at statup)
  • This change involves changes to Roon as well as our back-end services which facilitate communication between ARC and your Roon core.
  • If you are running your core on RoonOS (Nucleus or ROCK) then you will need to update to the latest earlyaccess build of RoonOS."


Hi everyone,

Thank you for taking the time to test this out, and in particular to those of you for whom this requires some hardware rearrangement or network reconfiguring.

The team is eagerly consolidating test results as reports come in here. In particular, we’re curious to hear how RoonOS users are faring (please be sure to update to the latest #earlyaccess RoonOS build here, if you haven’t already).

For those of you who have yet to post: the granularity of your report is up to you, but please include 1) your Core operating system and 2) a basic list or overview of your network hardware and setup. For example:

MacOS Core → Google Mesh → Verizon FIOS router

If the Roon Settings port test fails, please include any diagnostics or a description of the error message. We’re here to assist with any questions and the team is very grateful for the time and expertise you’ve lent here.

1 Like

Edit: my ISP PlusNet in the UK is not ipv6 enabled

I’ll have a go at updating on Wednesday.

1 Like


This seems to be working for me if I did what you are desiring…I checked the box for IPv6 on my Router and disabled IPv4 (I think I did this right)! My set-up:
ISP: Comcast Xfinity
Modem: my own Arris Surfboard modem
Router: Eero Mesh
Roon Core: SonicOrbitor i9/Linux connected via Ethernet to the Router.
Streaming music via ARC to by office wifi hotspot as I type…I did have some dropouts but not sure it is because of this change or the crappy signal the hotspot gets inside the hospital…so I changed ARC settings from “Automatically pick best quality” to “Bandwidth Optimized” and no dropouts since.

Enabled IPv6 on the router (Fritzbox) for Vodafone Germanc, no success. My Vodafone account has a static public IPv4 address though (got that for ARC specifically) so not sure if this is expected to work then. Internet still works though with using “native IPv6 connection” on Fritzbox:

In this state I can reach most websites, though I can’t reach the Roon forum. However, I get this ARC error:

When I use “Use only IPv6” instead, I have no Internet at all:

I have the T-Mobile Home Internet and I am having problems still.

My network is: T-Mobile Home Internet > TP Link Deco router (mesh) > 2014 Mac Mini > iPhone 14 pro max
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“172.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I’m afraid I can’t contribute here. My Fritz!Box modem/router supports IPv6, and my Core is on Roon OS, but my ISP (Solcon) is still only using IPv4 in the internet connection…

1 Like

When i first started using Roon i had adequate(!) internet in the house and when ARC came out it worked relatively smoothly with little set up involved. But, as i realised the potential for Roon to work across my property (including my home office in a separate building) i decided to upgrade with FTTP; sadly this meant using a Nokia Modem/Router supplied by the ISP which is actually great for the internal network, but stopped ARC from being available.

This new addition to the early access build has given me back the ability to use ARC, it faltered at first with the inability to download music, but is now up and running and “feels” to be more resilient than it was when it was first launched.

I am very pleased and happy to be able to re-expand my listening pleasure, thank you Roon.

1 Like

Same experience here with fritzbox and Tiscali Italia.
The only option that works is “Use Ipv6 with a tunnel protocol”


I successfully installed “early access” with the following result:
“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“82.hhh.iii.jjj”,“actual_external_ipv6”:“2001:aaa:bbb:ccc:ddd:eee:fff:ggg”,“router_external_ip”:“null”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Basically like Tailscale? That stopped working for me recently.

What internet are you using?

Hi, @Matthias_Goetze, thank you for your feedback. Could you, please, provide more data about the folloiwing:

  • Internet provider and your location
  • Network setup



Hi Ivan,

my Internet provider is 1&1 and location is germany.

(sorry it’s all in german)

1 Like

see answer to Ivan


I know with T-Mobile home Internet you cannot adjust any settings on the modem itself. Router won’t help either.

Yeah you at least have more settings than I do.

a quick note about IPv6 and using your own router… I’m tagging @connor just to make sure they see this.

IPv6 does not support NAT. If you’re using your own router with IPv6 you’ve probably broken IPv6. Let me expand on that…

Internet → ISP supplied router → Your stuff

When you connect your stuff to your ISP supplied router then Your Stuff gets IPv6 addresses, publicly routable IPv6 addresses, assigned by your ISP supplied router. Everything works fine with v6.

Internet → ISP supplied router → Your Router → Your stuff

Your Router will acquire an IPv6 address from ISP supplied router but it has no IPv6 addresses for Your stuff. You’ve broken IPv6 for Your stuff. Remember, you can’t NAT here it’s IPv6.

The solution to this is called Prefix Delegation (PD) but most ISPs don’t support it and most consumer equipment doesn’t support it either. Without PD there is no way to get IPv6 addresses assigned to Your stuff.

I bring this up because… If you are IPv6 only then your Core probably needs to plugged into ISP supplied router for any of this, very nice thank you, IPv6 support from Roon to be of use to you. Unless you know that PD works properly on your network.