Wightham Telecom: CG-NAT Blocks Port Forwarding w/out Requesting Static IP for Fee [See Staff Post]

Roon Core Machine

Intel NUC 11 i3
Ubuntu, latest bersion

Networking Gear & Setup Details

Deco M4R mesh system

  1. Who is your internet service provider?
    Wightham telecom in Stratford Ontraio

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 167.aaa.bbb.ccc:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“167.aaa.bbb.ccc”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I called my ISP and they assured me that all ports are open on their end and that if I set up port forwarding on my system, which I have, it should work, However, they do use IPV6…. I’m wondering if that’s the problem.

I have two homes and I have easily set this up successfully in the other home on my Bell 3000 router. I use the same NUC in both locations - I take the NUC from house to house.

@Ian_Hudson, it appears your ISP, Wightham Telecom, uses CGNAT (Carrier Grade NAT) in their network based on 100.64.xxx.yyy address in your ARC error message. At the present time, ARC cannot work on network using CGNAT. CGNAT is used in some cases to provide multiple users with a shared IP address that are in short supply.

Can you contact Wightham and see if they can either turn off CGNAT for your account or if there is an option for you to get a public/routable IPv4 address?


Thanks. I will contact them and ask.
Pretty sure The IPV4 is not possible. They told me The whole town is IPV6.

I got the answer from my ISP……

To port forward behind and ipv6 server you need to have a static ip. There is a fee for this , please call custoemr service

So that’s that - not a ARC issue. I will have to decide if I wish to pay the monthly fee, whatever it is.

Thanks for your help.


Hi @Ian_Hudson,

Thank you for reporting in on your progress, and I’m very sorry to hear that you’re joining the ARC users stranded by carrier-grade NAT without paying extra to your provider.

Note that Roon is diligently researching alternative solutions to port forwarding and additional workarounds in the meantime that will help democratize access to mobile playback to more users, regardless of the infrastructure of their service provider. Your posts here will assist in this effort, and I’ll add your service provider shortly to the list of known CG-NAT blockages here: ISPs and Routers: List of Known Solutions and Workarounds

In the meantime, please take a look at the unofficial, alternative solutions to port forwarding accumulating in the #tinkering and #roon section, like this: Tailscale implementation with ARC to circumnavigate ISP CGNAT

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.