Ziggo ISP-Supplied Modem/Router: Roon arc external ip problem

Henk, thank you, this is helpful. I agree with @Rugby’s question to ask Ziggo if they use CGNAT because your ARC error message is not quite the same as a double-NAT error message.

If CGNAT is used within Ziggo’s network, then one option is to request a static IP address for your public IP address. If CGNAT is not used by Ziggo, can your Ziggo router be configured for port forwarding?

Thanks Robert. I will contact Ziggo and let you know after.

1 Like

No need for a static IP, but for a public IP. See this thread:

Hi @Henk_Beijsens ,

I use Ziggo with a ConnectBox without a problem. Do you have the same box?

Hi Joost. I use my own Orbi router, but now I found out that when I change the wi-fi to the Ziggo box the Roon Arc connects correctly. So, I have to get in touch with Ziggo (for now when I’m out of the house I just change to the Ziggo wi-fi to use Roon Arc.)

Roon Core Machine

2017 MacBook Air

Networking Gear & Setup Details

Ziggo (Internet & TV, using the wi-fi router on their modem)
KPN NL (My phone/mobile internet provider)

Connected Audio Devices

iPhone SE (2020 model, 64 gb storage)
Terratec Aureon 7.1 USB sound card connected to a set of Presonus Eris 4.5 BT monitor speakers.

Number of Tracks in Library

About 30000

Description of Issue

I have the same issue. At home on wi-fi ARC runs perfectly fine. But if I turn off wi-fi and my iPhone uses my 4g connection nothing would play and often getting the “poor connection” message. Which is odd because all other apps that I’m using have 0 problems with my 4g connection. This includes Qobuz, Apple Music, VOX, HBO Max and Amazon Prime. Even streaming full hd doesn’t result in stutters.

I’ve tried ARC as well in my car and at work, but resulting in the same issue. On top of the app you see a progress bar that keeps spinning without end, and then the “poor connection” message will show up, or not at all.

1 Like

Hi @SandsOfArrakis,

I’ve merged your thread for visibility with another user with the same ISP-supplied modem from Ziggo.

First off, are there any diagnostics displayed in the ARC Settings tab in Roon? It’s likely that you’re encountering a double-layer of NAT that is preventing the port forwarding from automatically configuring. Please post any diagnostics visible (make sure to censor IP addresses for security) and the team will be best equipped to support you.

First, please review our port forwarding Help Center guide.

A couple other questions that will help us determine the source of the block:

  1. Do you have a second router in your setup?
  2. If you don’t have a second router in your setup, then it’s possible you are bumping up against Ziggo’s dynamic IP address assignment, or an issue with assignment in your router. You can verify that your router is set to IPv4, and not IPv6, just for due diligence.
  1. I suggest you reach out to Ziggo’s support team to inquire if Ziggo can provide your account with a static IPv4 address if nothing works.

Hi @Henk_Beijsens,

Did you make any progress with Ziggo on your setup to report back here? Could help others with a similar setup.

Hi @Henk_Beijsens,

I wanted to reach out, as it’s been some time since I last checked in on the issue you were experiencing. The team investigated routine diagnostics from your account, and it would appear that ARC has been able to successfully connect in what would appear to be mobile playback conditions (4G/5G). Have you been able to successfully contact your ISP to bypass their carrier-grade NAT on your account?

I had the same problem. I was not able to access my Roon Core with Roon arc.

My setup:
ISP: Ziggo > Arris TG2492LG (router) > Unify Dream Machine Router > Unify Switch > Roon Rock

Solution: I had a chat with Ziggo to put the router in Bridge Modem, which results in:

-Disabled firewall
-no WiFi
-no NAT
-no DHCP

Next to this I added port forwarding on the Unify router, using the IP from the Roon Rock with port 55000.

Now it works. So happy I can work on my playlist and other music management with Arc while on the train :slight_smile:

Well I finally have my setup working with ARC. And I didn’t have to get Ziggo to put the Ziggo Mediabox into bridge mode. So it still has its DHCP, NAT, WIFI and firewall enabled. The only thing I disabled on both the Ziggo box and my ASUS router is UPnP.

Port forwarding rule set so my ASUS router which is connected through Ethernet gets data forwarded to it.

Forwarding rule set in my ASUS router.

With these settings Roon ARC works like a charm here. Rock solid connection to my Roon Core which is running on a 2017 MacBook Air connected through 5g wifi.


This is because you remove a double NAT when using the Wifi direct to Ziggo router.

Core → |Orbi / NAT1| → |Ziggo router / NAT2| → Internetwebtubes

Core → |Wifi| → |Ziggo router / NAT1| → Internetwebtubes

If you’re going to use 2 routers you need to port forwarding on both.

  1. Ziggo ARC port → Orbi
  2. Orbi ARC port → Core

I also had a arc problem with ziggo/Linksys mesh at home
Turned out: Ziggo had, during an update, un-bridged the ziggo modem hence no arc for.

Since ziggo modem is back in bridging mode all things are fine.
My Linksys mesh is handling all ip numbers etc.

1 Like

Hi @Henk_Beijsens and @Jasper_Kunst,

Happy New Year and I hope this response finds you well. Are you still having difficulty with ARC?

3 posts were merged into an existing topic: Starlink (ISP) with ARC: CG-NAT Requires VPN Workaround (See Staff Post)

Hi all, I get a slightly different error on ARC but am with Ziggo provider as well

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“84.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“84.aaa.bbb.ccc”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I have their standard Sagemcom Smartwifi modem with portforwarding on.
Tried disabling UPnP with no effect.

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“84.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hello @Dolle_Dries,

Could you post a screenshot of your port forwarding rule and a screenshot of the port Roon is looking for Roon Arc. This can be found in the Roon App under Settings → Roon Arc.

Kind regards,


Hey @Maarten_Duits thanks for your help.

After disabling UPnP and setting it back on I now have a second problem that I can’t see my streaming devices anymore both in Roon and other music software.

Hi @Dolle_Dries,

Could you change the protocol to TCP/UDP (or sometimes it says “Both”) in your port forwarding rule. I know Arc only needs TCP, in my case i needed to set it on “Both” (my isp is KPN).

Hope it helps.

Kind regards,


Hi @Maarten_Duits, unfortunately after changing the protocol to ‘UDP/TCP’ I still get the same exact error.