Ziggo ISP-Supplied Modem/Router: Roon arc external ip problem

I had the same problem. I was not able to access my Roon Core with Roon arc.

My setup:
ISP: Ziggo > Arris TG2492LG (router) > Unify Dream Machine Router > Unify Switch > Roon Rock

Solution: I had a chat with Ziggo to put the router in Bridge Modem, which results in:

-Disabled firewall
-no WiFi
-no NAT
-no DHCP

Next to this I added port forwarding on the Unify router, using the IP from the Roon Rock with port 55000.

Now it works. So happy I can work on my playlist and other music management with Arc while on the train :slight_smile:

Well I finally have my setup working with ARC. And I didn’t have to get Ziggo to put the Ziggo Mediabox into bridge mode. So it still has its DHCP, NAT, WIFI and firewall enabled. The only thing I disabled on both the Ziggo box and my ASUS router is UPnP.

Port forwarding rule set so my ASUS router which is connected through Ethernet gets data forwarded to it.

Forwarding rule set in my ASUS router.

With these settings Roon ARC works like a charm here. Rock solid connection to my Roon Core which is running on a 2017 MacBook Air connected through 5g wifi.


This is because you remove a double NAT when using the Wifi direct to Ziggo router.

Core → |Orbi / NAT1| → |Ziggo router / NAT2| → Internetwebtubes

Core → |Wifi| → |Ziggo router / NAT1| → Internetwebtubes

If you’re going to use 2 routers you need to port forwarding on both.

  1. Ziggo ARC port → Orbi
  2. Orbi ARC port → Core

I also had a arc problem with ziggo/Linksys mesh at home
Turned out: Ziggo had, during an update, un-bridged the ziggo modem hence no arc for.

Since ziggo modem is back in bridging mode all things are fine.
My Linksys mesh is handling all ip numbers etc.

1 Like

Hi @Henk_Beijsens and @Jasper_Kunst,

Happy New Year and I hope this response finds you well. Are you still having difficulty with ARC?

3 posts were merged into an existing topic: Starlink (ISP) with ARC: CG-NAT Requires VPN Workaround (See Staff Post)

Hi all, I get a slightly different error on ARC but am with Ziggo provider as well

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“84.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“84.aaa.bbb.ccc”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I have their standard Sagemcom Smartwifi modem with portforwarding on.
Tried disabling UPnP with no effect.

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“84.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hello @Dolle_Dries,

Could you post a screenshot of your port forwarding rule and a screenshot of the port Roon is looking for Roon Arc. This can be found in the Roon App under Settings → Roon Arc.

Kind regards,


Hey @Maarten_Duits thanks for your help.

After disabling UPnP and setting it back on I now have a second problem that I can’t see my streaming devices anymore both in Roon and other music software.

Hi @Dolle_Dries,

Could you change the protocol to TCP/UDP (or sometimes it says “Both”) in your port forwarding rule. I know Arc only needs TCP, in my case i needed to set it on “Both” (my isp is KPN).

Hope it helps.

Kind regards,


Hi @Maarten_Duits, unfortunately after changing the protocol to ‘UDP/TCP’ I still get the same exact error.

Hi @Dolle_Dries,

Could you go to https://portchecker.co. Your public IP will be shown there (so don’t post a screenshot of it anywhere). In the port number field enter 55002 and hit the “check” button.

If everything is configured correctly the message should be that the port is open.

Let me know what the response is.

Kind regards,


Good morning @Maarten_Duits, the checker says port 55002 is closed


What it shows, is that from the outside world your machine (over port 55002) isn’t visible. That’s also the reason why Roon Arc isn’t working. Could you try the following: in the Roon App under settings → Roon Arc change the port number to ie. 44135. Change your port forwarding rule to this number. Then try Roon Arc and the port checker for this new port number. Some ISP’s block some range of port numbers. Don’t know if this is the case with Ziggo. It’s worth a try.

Maybe you already did it, but after changing the port forwarding rule, did you reboot your router and core?

Kind regards,


My 2 cents ( had also issue with RoonArc). Ignore if not relevant.

Make sure your upc router is in bridge mode ( if required for you home-WiFi)
I have Linksys mesh in-house dealing with all the IP-adresses. Upc router in bridge mode. RoonArc works.

Hi @Frits_Van_Der_Veer, my computers and streamers are all hard wired and I use Deco mesh for Wifi.

Hi @Maarten_Duits that still doesn’t work.

I have contacted Dell (for support on my new desktop) without any luck.
Next step is contacting my ISP.

Hi @Dolle_Dries,

You only have the ziggo router or are the more routers in the setup. If so, please write down the exact setup.

Kind regards,


Hi @Maarten_Duits, my set-up is as follows:

Modem Router
The black Ziggo Sagemcom modem provide by ISP Ziggo
(SmartWifi modem (zwart) | Klantenservice | Ziggo)
→ Sits in the basement

Two Netgear switches (GS108T), both directly connect to the Ziggo modem
→ first one sits on the second floor
→ second one sits in the attic provides fixed internet for my LAN

My working, listening and DJ room in the attic

Local Area Network and devices
My old W7 Windows PC
My new W11 Windows PC (Dell XPS 8950, 12th gen i7-12700k 3.60GHz, 16GB Ram, W11 Home 22H2)
My Mac- (Traktor DJ Software, +Mixing gear) and Windows laptop
My old NAS (ReadyNAS) and new NAS (Synology)
Two NAIM streamers (UnityQute and NAC N-272) → I use upnpbridge software to make them proper endpoints)

Roon Core is installed on the W11 computer with a collection of approx 350k tracks.
I also use MediaMonkey 4, which is installed on both my old and new desktop computers.

Lowband Wifi on the Ziggo modem is on as the old Logitech Squeezebox doesn’t work with the modern Deco’s (hence not in bridge mode). This is for internet radio and streaming my collection via roon in the Kitchen (sits in the basement).

3 TP-link Deco SmartWifi pods
→ 1 directly connected to the modem in the basement
→ 1 on the ground floor
→ 1 on the first floor
Provides enough fast Wifi coverage for the whole house.

Hi @Dolle_Dries,

Are these switches managed or unmanged switches? If it are managed switches, maybe there is something wrong. Is the W11 machine connected via Wifi of direct via cable to the ziggo router? If WiFi, is it connected via the TP-Link smartwifi pods?

Kind regards,