1.8 will not fully load on Nucleus Core

1.8 started downloading on my Nucleus Core and then stopped. Based on the status bar, it looks like it is 60% loaded.

My Nucleus Core is connected to my network via an ethernet cable.
I have Roon on my MacBook Pro, my iPhone, and my iPad. Operating systems are up-to-date.
My Roon apps on all three devices from the Apple Store are up-to-date. “1.8 (build 748) stable”
The error message I receive is “Software update needed. Roon is trying to connect, but it looks like one or more devices on your network need a software update.” The message associated with the Remote Core (Nucleus) is “Downloading…”
I checked multiple times that my apps are 1.8 so there are no devices I’m aware of that need updated solftware.

Due to this problem, I cannot use Roon at all. Please help soon.

How long has the download been stuck at 60%.

Thinking I’ve read on other posts like this that cycling the Nucleus will cause the update to start over and complete.

I had the same problem.
Reboot of NUC via WEB-Console solved the problem.

Rebooting worked. Thanks.