4.18.0 does not start from roon

I changed from 4.17.2 to 4.18.0. Settings remain the same.
Tiadal MQA sources start.
However, local non-MQA sources and Tidal non-MQA sources do not start.
Again, I changed from 4.18.0 to 4.17.2, resulting in no problems.

Have your MQA settings changed?

HQPlayer doesn’t know if the source is local or non-local or if it is MQA or not MQA.

If you are on Windows with Intel CPU, please check if you have downloaded before my hotfix release few hours ago. If necessary, please re-download and re-install.

My environment is ubuntu 20.04 with intel cpu.

OK, I have not seen problems in that environment. Any errors in HQPlayer log file when something doesn’t work?

Where can I check the logs?

HQPlayer4Desktop.log under “~/.hqplayer” directory. Note that you need to enable log file in HQPlayer settings and then restart HQPlayer to gather a full log. Error lines are prefixed with ‘!’ or ‘#’ character.

I checked.
There was an error.

Here is the log.

2022/04/15 23:32:32 Rate or blocksize change triggered
2022/04/15 23:32:32 Rate: 44100, block size: 2352, frame size: 588
2022/04/15 23:32:32 Block size: 2352 (sample: 2)
! 2022/04/15 23:32:32 clHQPlayerEngine::Execute(): Out of memory!
2022/04/15 23:32:32 Stop request (reset)

  • 2022/04/15 23:32:32 Playback engine stopped
    & 2022/04/15 23:32:32 Stop…
    & 2022/04/15 23:32:32 …stopped

Ahh, that’s the same error that is happening on Windows too. Please try installing the “avx2” package instead if you have powerful enough CPU to run it.

Another temporary workaround is to make “Multicore DSP” checked instead of grayed.

I have tried installing the “avx2” package.
However, the result is the same.
The logs are also the same.
I also confirmed that avx2 is enabled in the processor info.

4.18.0 started!!
Thank you very much.

I await a permanent response.
By the way, do you need avx2 for the next version too?

For Ubuntu, there will be two builds for the foreseeable future. The generic one, and the “avx2” one. Former works from SSE4.2 upwards while the latter requires AVX2 but tends to perform better on latest CPU generations and especially on AMD.

Thank you for your prompt response.
I look forward to your future development!