Add an option to play inaudible white noise during resync delay

Core Machine
Ubuntu 20.04, Roon Core 1.8.795, xcp-ng VM (2 CPU, 4GB RAM)

Network Details
1Gb wired

Audio Devices
Raspberry Pi 4 with HifiBerry Digi+ → SPDIF into Denon AVR-X3400H (optical)
(running RoPieee)

Description of Issue
Whenever the PCM format changes (eg. different sample rate), there is a gap of approximately 0.5s until the Denon AVR detects the change. I tried to enable “Resync Delay” as I thought it was exactly for this case, but the gap remains (it is now 0.5s + whatever resync delay is set to).
The AVR status display shows “PCM ZERO” during the resync delay, and then “PCM” when the actual track starts.

My guess is that the AVR tries to be clever and detects PCM with all-zero samples. I was also able to reproduce this by playing a sample WAV file containing 10s of “zero” samples.

I think this could be fixed by playing inaudible white noise (similar to what Audacity creates with “Generate” > “Silence”) during the resync delay, so the AVR won’t see an all-zero PCM stream.
Would it be possible to add this as an option in a future update?

HI Michael,

Are you asking support a question or making a Feature Request. If you are making a request, I can move it over to that section.

Yes I guess this would be a feature request :slight_smile:
Maybe you can also change the subject, something like “Add an option to play inaudible white noise during resync delay”?

Thanks for your help.

This is correct. Digital silence will not work well for Resync Delay with some equipment. Many DACs mute their outputs when presented with digital silence – probably to inflate SINR. Stereophile has documented this in test bench measurements for years. Inserted dither noise would be more functional for Resync Delay.

AJ