Adding Roon Nucleus to a Crestron System

(Chad Johnson) #1

Core Machine (Operating system/System info/Roon build number)

Version 1.0 (build 175) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unifi USG-XG-8 gateway, Araknis AN-310-SW-R-24-POE, Ubiquiti AC HD WAP

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos and Crestron Media Player

Description Of Issue

Nucleus will not connect to the Crestron Media Player

(Noris) #3

Hi @Chad_Johnson1,

Thanks for reaching out to us here. Can you please confirm if you have followed the module pairing instructions on our Knowledge Base Guide?

  • Update Nucleus and Roon Remotes to the newest Roon version
  • Unauthorize any existing Crestron extension in Roon Settings -> Extensions -> View
  • Add the Nucleus’ IP address in the Crestron module RoonSystemModule symbol
  • Compile and upload the module to the processor
  • Reboot the Nucleus from the WebUI or power button
  • Enable/Pair the new module in Roon Settings -> Extensions
  • Configure the new module in Roon Settings -> Extensions
  • Reboot the Nucleus again after the module is paired

Have you made sure to configure the zones via a Roon Remote in Settings -> Extensions?

(Chad Johnson) #4

Noris,

I saw this online but when I connect to the Roon with it’s IP address I don’t see where to update it or unauthorized any existing Crestron extension. This is a new install. Is there any way I can get someone to give me a call to help with this?

(Noris) #5

Hello @Chad_Johnson1,

We do not offer phone support but we would be more than happy to assist you right here on the Community website.

When we resolve issues on Community, it ensures that our entire team has access to the discussion and can weigh in as needed. This means that not only can our support team contribute, but so can our QA team, developers, and senior staff.

As for this issue itself, can you please confirm what exactly you are seeing in Roon Settings -> Extensions? If you can provide a screenshot by using these instructions it will help me better assist you. This is an example of what is should look like once paired:

I would confirm that you have authorized and paired the Crestron extension first, and make sure that you have set each of your zones appropriately via a Roon Remote via the following menu:

image

Can you share a few screenshots of how these two menus look like on your end? Also, can you please specify the model of the Crestron processor are you using?

(Chad Johnson) #6

The Roon was connected and working fine and then we changed out the Crestron Processor and now it is not connecting. Do i need to go back into the settings/extensions and delete the old Crestron processor and confirm the new one?

(Noris) #7

Hi @Chad_Johnson1,

Yes, when you switch Crestron processors, you will need to recompile the module and upload it to the new processor. Then you need to perform the Pair and Configure the new extension using the previous instructions I listed:

Do let me know if that helps!

(Chad Johnson) #8

I unauthorized the old Crestron extension and then rebooted the Roon. Then i went in and add in the new Crestron extension and everything started working again. Then on September 3rd i received this message. Do you know what would cause it?

(Noris) #9

Hi @Chad_Johnson1,

Seeing that message indicates that your Roon Core has not communicated recently with the Crestron module, but t is possible that this was referencing the older build you had installed before authorizing the new build. Is the Crestron module still working as expected on your end? Are there any issues you’re seeing?