After downgrading to from 2.0 to 1.8 Legacy I have the message "...incompatible with your database"

Roon Core Machine

macOS 10.15.7 (Catalina)
iMac 3.4ghz Quad Core intel Core i7

Networking Gear & Setup Details

Connected Audio Devices

Node (through ethernet cable)

Number of Tracks in Library

Description of Issue

After downgrading from 2.0 to 1.8, due to speed problems following the guide previously posted within these walls and installed the server and the 1.8 Legacy on the core, I’ve found out the following and strangest of behaviours.

My Roon remote in my iPhone 14 and my Macbook Air work seamlessly… but the Roon app on the core displays the infamous message of database incompatibility … It means the remotes and my Node are communicating with my core, but the Roon app on the iMac will display the aforementioned message.

How is this possible? (I have no problem with losing the database and starting from scratch – I don’t have a 2.0 backup), so why is the program not giving me the option, as my iPhone and MacBook did, to start all over again? What am I doing wrong?

On the plus side… the downgrade really worked… I mean the speed problems of communication between the remotes and the core are solved, just this thing with the software…

Any suggestions?

i am afraid this is the expected behavior; starting with Roon 2.0.3, resulting backups are no longer compatible with 1.8 Legacy version (Roon 2.0.3 and ARC 1.0.4 are live!)

I am aware of the database issue and I’m okay with starting from scratch since all my music is stored in an external hard drive that will take the core three hours to index–no issues with this. I’m talking about being unable to open roon 1.8 core program so it can start indexing…

Can you give us a little more detail on what precisely you have done and what your setup is now? You said you have: “installed the server and the 1.8 Legacy on the core”.

Have you installed both the Roon Server and Roon packages on your iMac, or just installed the “all-in-one” Roon package for MacOS using the link in the 1.8 <-> 2.0 Migration FAQ?

Can you post a screenshot of the iMac Roon’s error message?

  1. Open Finder and click Go in the top bar
  2. Hold down the Option key (or Alt)(⌥) to unhide the Library folder
  3. Click the Library folder
  4. Find and trash (or rename) the Roon or RoonServer folder
  5. Try to open Roon 1.8 again, it’ll create a fresh database

That did the trick!!! 1.8 working now.

Thank you

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.