Airplay 2 Question on enabling Apple TV

The new Airplay 2 is working great with my system. I have 7 HomePods around the house and have not used them for Roon up until now, as the stereo pairs did not work well enough to bother. So, my question is around enabling Apple TV. It asks for a password, so I went into the airplay settings on the Apple TV and enabled the password, and I was then able to connect. Now when I go to play to a HomePod stereo pair it also asks for a password. I did the password and connected them too. So all is working, but do I always need to have passwords enabled, or only when I first connect? I’d like to disable passwords so it does not bother the family members doing airplay outside of Roon. Not a big issue though, and thank you Roon for adding airplay 2….it has been the missing feature for me.

For what it’s worth: I disabled my Macbook Air from Roon, so that I could again enable it - to check if that would somehow “switch on” the new AirPlay 2 feature, which was struggling at first.

Well, I couldn’t enable it again! Roon asked for the code and I checked - I had disabled it in the macOS systems settings (the Mac still showed a code on the screen, obviously because Roon asked - but it didn’t work when keyed into Roon).

So, I couldn’t get anywhere with it - left the thing waiting for more time and patience. But when I later checked Roon, it had enabled it by itself.

Maybe this would happen to your speakers as well?

Yes it seems to take a bit to get things coordinated to notice AP2 endpoints after running.