Airplay but not Sonos

I recently upgraded some older Sonos speakers to newer ones. In the process, I no longer have the ability to connect to them as Sonos device; I can only see them as Airplay devices.

Does anyone have a theory on why that might be? TIA!

Hey @Ian_Glazer

Have you tried rebooting the system running your Roon Core?

Under Setting - Audio you can enable and disable. You likely have multiple “devices” in Roon for each Sonos speaker. I disable the Airplay versions. You might need to enable them explicitly.

Thanks all. I tried both to no avail. Here’s a screenshot of my Audio Settings.

I have the same problem. Did you get them working again?

Yes and no. I have my Sonoses on a separate VLAN from my Roon server. I used to be able to get to them with this config but apparently either something has change in the way the server looks for Sonos endpoints or something has changed in my network config. By moving one box onto the same VLAN as the Roon did the trick