Album Versions Issue

The “Version” tab when viewing albums do not show me the other versions I have in my personal library. Perhaps it’s a setting (I have ‘Show Hidden Tracks and Albums’ toggled ‘on’ in Settings) or metadata I’m missing.

The example here is I have the TOOL album ‘10,000 Days’ in FLAC 16-bit (ripped from CD) and 24-bit (bought via HDTracks). As can be seen in the screenshot both albums appear in Album search view.

However, when either album is selected and “Version” tab is engaged the other album does not show and ROON still states “1 Library Version”.

This is typical for every instance of multiple album versions I possess. I have some that are FLAC, 24-Bit, and MQA versions of same albums but they are never shown under Versions.

Am I missing something? Ideas?


My first though is Roon seems them as completely separate albums because they are named differently since one as the “[24-bit]” in the album title. Are both albums identified by Roon? or is either unidentified? You should also try turning off that ‘Show hidden tracks’ setting because its purpose is to show both versions of an album as if they were separate. Maybe try turning off there setting first, and if that doesn’t work then try naming the two albums the same thing

1 Like

Hey thanks for the quick reply. Originally the “Show hidden tracks and albums” was off. I turned it on when I noticed this situation with versions not showing to see if it would help. I’ll turn it back off.

In regards to the album titles I will rename (remove the [24-Bit] appendage) so they are the same and see if that does the trick. I thought all these settings for Album Version parentheses types would help with that though.

Okay, I’ll do some testing ASAP.

Thanks again!

Right, so having those settings on means that roon includes whatever is in there as part of the title. If you tune off album version in [square brackets] then stuff in this brackets will get ignored which is what you want. that way you have whatever is in the brackets as a tag but roon won’t read it.

Renaming the album so both are same is the only way I could get to work. The parentheses options seemed to have no effect.

It does kind of mess up other music library apps (i.e. BluOS app) because now Album sort lumps everything together. But I can live with it since ROON will become primary in my usage.

You may have to mess with the other settings like “Extract Album Version from file path” and/or “Extract Album Version from album title”. I think the “extract album version from brackets” is maybe specific to the file path and maybe overruled by the “extract album version for album title”. So you may have to turn both off? That would be my best guess.

Yeah, I’ve been doing lots of trial & erroring with these settings but it’s not very intuitive, imo. Thanks for all your thoughts again.

I think there’s an actual bug with the parentheses/brackets options. No matter what I tried I could not get album versions to work as intended or what I think is intended.

So after many hours of experimentation I ended up taking the albums into MP3tag and stripping out the appendages from the album titles. Also discovered that Disc # and track #’s needed to be the same across same albums. Then I added a custom tag VERSION to the files and used “Original Release”, “Remaster”, and/or “Remaster MQA” to the relevant albums. I set ROON to use VERSION tag in Library Settings and turned off the other options (not working anyway). I did a Force Scan in ROON Storage Settings and bam! it all worked. The only real hiccup is if track #’s changed I found I had to remove the entire album from the Watched Folder, then force scan, then add the folder back, and force scan again.

This is a real tedious task so now I have the next couple of weekends to straighten things out. I’m a ROON novice but I do think the software is not functioning 100%

If there’s an easier method (ROON should have been the easier solution!) I’m still open to suggestions.

This seems to be working for me, at least with parentheses (didn’t try brackets etc.), but only on file import (which may make sense as it is in the import settings). However annoyingly not for Qobuz album titles, so I have to edit them manually

I’m having the same issues here, multiple duplicates is different formats ( dsd, flac) not showing up under the versions tab. My albums don’t have any appendages in their album names so I’m wondering why not?