Albums not showing after Build 880 is installed

Roon Core Machine

QNAP TS251 running firmware ver., QTS 4.3.4, Celeron processor and 8GB RAM

Networking Gear & Setup Details

Billion 7800 Router running through Netear 8 port unmanaged switch

Connected Audio Devices

Meridian 218 Zone Controller

Number of Tracks in Library

Library of about 2500 albums

Description of Issue

I updated the system with the prompt on my remote to do so. Since then it connected once but said I had no albums AT ALL! I then restored from the latest backup which was from last night and now it shows this on startup…

…and if I press the connect button the remote appears to hunt for the core but nothing else happens. This is happening on my PC’s remote and my iPad. This latest update has wrecked my system!

The core appears to have reconnected but only up to a point. It’s still hunting and it still tells me I have no albums! If I try to load albums from my bookmarks, I get “error loading saved page” in the middle of the screen.

I have also tried reloading my albums from scratch and I get this…

Trying to force a rescan of this folder does nothing.
Both the core and remotes are on Build 880.

A post was split to a new topic: Some albums from NAS no longer recognized after update (880)

Hey @Alan_McMillan,

Thanks so much for reporting the issue and all the subsequent updates. We’re grateful for your efforts in getting things moving.

Would you please disable the network share to your NAS in Settings → Storage, restart your Roon Core and set up your NAS as a storage location again:

Thanks :pray:

I’ve reinstalled the Roon server app and that gives me a new library that is a mess as I’ve lost all my curated details. My issue is with the backups that cannot be restored. I had occasion to restore from a backup last month and I tried to restore from that very file and it failed. Why would that happen? The database backup was clearly not corrupted then so why is it now? I’m convinced there is something very wrong with build 880 and I would like to have 850 back please. My library has been WRECKED by this obsessive updating nonsense. Why can’t you leave well alone??? If it’s not broke, DON’T FIX IT!!

1 Like

Hello @Alan_McMillan ,

We are investigating this issue with QA at the present moment, it appears that this issue may have been due to a failure with images being migrated properly.

Can you please upload your Roon database (the entire RoonServer folder) that exhibits this issue to the following location and let us know afterward?

Thank you!

1 Like

A post was split to a new topic: No connection to Ubuntu Core

2 posts were split to a new topic: Ubuntu connection issue after update [Solved: Port issue]

Hi @noris
It was a long day yesterday. I finally realised I could download the folder from my own NAS share link! DUH!
I’ve therefore uploaded the Roon_Server folder as requested to that Zoho workdrive link you gave me. I started doing so last night but it’s just over one gig and my upload speed is less than a meg per sec so it took until five in the morning to finish.


Alan McMillan

1 Like

Hi @noris

One other thing has occurred that may point to what’s going on here. I tried to update my account avatar just for the sake of seeing what worked and what didn’t. It gave me the opportunity to browse to a photo and select it. It then showed in the little round preview window…but it wouldn’t save. I’ve tried it three or four times now and there’s no change. It’s as if there’s something getting in the way of the remotes accessing the core files on the NAS. It’s not my firewalls because I’ve turned them both off to eliminate them from the issue and it made no difference.

Alan McMillan

Thanks for sending that database over @Alan_McMillan , I’ve forwarded it to the QA team.

You’re welcome @noris
I really hope something comes of this. The idea of having to re-curate my entire library again scares me witless.

1 Like

Hi @noris
I’ve just installed the Build 882 update and…wait for it…everything’s back!!
I don’t know how you did this but I have EVERYTHING back, tags, bookmarks, playlists…the LOT. The mystery for me is that in uninstalling and reinstalling the core I deleted everyhting in the Roon_Server folder and the only way I could be seeing what I have now is if the new build restored one of my backups. It’s interesting to note given this hypothesis that my most recently added album is missing altogether and I can’t get it to appear by removing it from its folder and then replacing it hoping Roon will find it.
Beyond that, I am a happy bunny and thanks go to all for pulling out all the stops and getting out in front of this. I hope everyone who has been through this nightmare episode will get their libraries back now or very soon.

1 Like

Hey @Alan_McMillan ,

Glad to hear you got your library back with the new Roon release! I hope you and your loved ones have a great holiday celebration and that you have access to all your tunes :musical_note: !


Build 882 sucks! I’m showing a 1/10 of my artists that what I should have before the update. Last night was showing 1/3 of my artists then this morning I was showing 50% of those I was seeing. Soon I won’t have any artists in my database. I can search for the artists that aren’t shown on the artist page and they all come up fine so they are out there.

Why do I upgrade Roon soon after a new release is announced? EVERY TIME for the last handful of upgrades they always have corrupted things or couldn’t even get to your external disks. Why can’t these developers test their upgrades properly? I worked in IT for over 43 years and if my developers would perform like this, they wouldn’t be with the company long. Just saying


I have gone from around 5,000 albums to 500! I had the problem, rebooted Roon and the problem seemed to be solved, but, today I appear to be back to square one. I am presuming that the solution being presented here is to completely uninstall and then reinstall Roon.

Thanks @noris
I’m in Italy now for three weeks over Christmas with relatives but at least now I can relax and stop worrying about Roon.
I hope you and yours have a great Christmas too.


Paul- Why would we have to do this? Does this make a lot of sense? Today, after you completely rebuild Roon you get your 5000 albums back, are you sure that tomorrow you won’t see 2500? What triggered this problem? Why wasn’t this found in their testing?

I have tens/hundreds of hidden albums, albums with modified metadata, if I totally rebuild Roon from scratch, all of this goes away, correct? If this is true, it’s unacceptable.

I have already restarted Roon a few times after the upgrade but I decided to restart it a few more times today. The 1st restart, it stated it needed a database update and the program update so it took a few mins longer to come up. I got 1900 artists of 867 after the 1st restart. This was an odd msg. Restarted it again and got 19xx artists which looks promising. Restarted again and still have 19xx artists and things look good right now.

Will this stay right from now on? Anything we need to do to protect this state of the app/database at this point of time?

Fortunately, I did not have to go back to square one - just had to reboot Roon and I now have my 5295 albums back.

The question you pose remains pertinent - we really shouldn’t have to do this.

You do not realise how much you have come to depend on Roon until it ceases to function properly. Theoretically I could return to playing CDs and relying on streaming services to fill in for thousand or so digital only files I have acquired or relying on one of the other less than ideal digital music players. Roon just makes it so easy and a rich experience (with ready access to other information and, in particularly the booklets) when it works (which to be fair has been nearly all the time).

I suppose, in one sense, it is trivial compared with the real problems of the world, but music brings so much joy on a personal level, and makes so many other problems seem not so important even if only for a brief period of time.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.