All Is Well after 521 Update

I haven’t come across any issues subsequent to the 521 Update.

After reading many of the recent posts indicating users dealing with a number of issues with the update it makes me think of all of the iterations of software and hardware Roon must deal with to get a stable release.


No problem here!

The Roon core apps run on various systems in my home, MacBook Pro, Mac Mini, Windows 10, and QNAP, all systems are updated to the latest OSes, firmware.

1 Like

Same here.

Initiated from the remote/playback pc, updated the core and the remote/playback, automagically. The remote seemed to get hung while the core was rescanning, but restarting the remote brought me right back to where it was and resumed further drama.

This update process is one of the things I really like about roon. Very slick.

(I noticed that the ‘no text’ issue some are reporting appears related a specific video card. I just have the bog standard built-in intel graphics. Also, my android tablet updated with no issues,)

1 Like

No problems here either. Just to be sure, I did a database backup before and after the upgrade from 511 to 521. I then uninstalled Roon and Roon Server completely from my Core server (Intel NUC running Windows 10), including deleting settings and the database. Finally, I re-installed Roon Server and restored from the backup.

Everything came up perfectly fine (as expected) after the restore. It’s been a while since I tested a Roon backup/restore, so I’m glad to know I can still depend on it. :slight_smile:

A post was split to a new topic: Android tablet not connecting after B521

Roon QA and Alpha testers run builds through a wide variety of software/hardware combinations. But the parameter space is huge, especially with networking, and somehow a few gremlins will always make it through the net.

Fortunately Support has some adept bug-squashers to call on. My favourite bug squashing tale involved a nasty intermittent bug in Album merge that resulted in previous Albums getting mixed in to the currently selected merge. Vova and I spent an afternoon (my time) trying to replicate it consistently without working out how to do so. When Brian looked at what we had done, he noticed that the bug occurred when I restarted my Remote. It was particularly satisfying to see that squashed.

1 Like

After upgrading to 521, my Chord Poly + Mojo stopped working as a Roon endpoint. I can see it, but nothing will play. Beware…

Thanks to the OP for starting this thread. Reading this board exposes you to every glitch any user has experienced, but it does not give you much of a perspective of how many glitch-free updates happen routinely. Thanks @Still-One for reminding us of how well this software works for the vast majority of users.

And to those who are the disadvantaged few: hang in there. Roon personnel are particularly dogged in their pursuit of bugs and glitches.


All OK here with Nucleus, Dell XPS 15, iPhone 6S Plus, iPad Mini 4, and even Nexus 7 (2013) streaming Tidal and Qobuz.

I heard this story second-hand, so excuse me if I flub some of the details… but I was absolutely flabbergasted by this diagnostic feat.

The protagonist of the story worked in the retail POS (Point of Sale/Cash Registers) department at medium-sized fashion outlet. The company had just finished a nationwide rollout of a new POS system, with every store getting re-wired for Cat5e at each terminal. They anticipated that there would be some growing pains and mishaps, but to their surprise the rollout was relatively painless… except for one store in Cleveland, Ohio.

The store had been running without issue for a week when out of nowhere the entire network dropped. IT was dispatched, they swapped out the switch and the store was back up and running. However, a few days later, they were called to action as it happened again. The electricians were brought back to replace nearly everything including power and ethernet cables. What do you know, a few days later the entire system went dark with no obvious culprit.

It’s at this point the protagonist is booked on a one way flight to Cleveland with the task of getting this figured out. Security camera footage is reviewed, network logging taps are installed, no stone will be left unturned. Eventually he gets up on the ladder to inspect the switch located in the ceiling. As he’s poking around by the switch he unsuspectedly gets one of the biggest static electricity shocks of his life. He comes down off the ladder and starts putting things together…

The switch was located by an HVAC return vent in the ceiling. Coincidentally, it was the winter months in Cleveland and the store had an assortment of wool products in the vicinity of the return vent. Further exacerbating this situation was the low-humidity commercial forced-air heating system in the store. Customers would come in and fondle the wool products, causing the fibers to be whisked into the air often in the direction of the return vent.

They pulled the network infrastructure out of the ceiling and ran the wires elsewhere. Problem solved.

It’s difficult enough to conceive of all of the possible hardware and software interactions that could cause something to break. To then have to consider the environmental factors… I’m glad we have @vova :grin:


Similar one location brownout, it was a technical lab and the kit was sat on a stainless steel workbench that ran round most of the room though not all of the kit was being knocked out.
My boss was the man sent out to investigate but the event was random though always of an evening and it was taking a long time to diagnose.

The reason it took some time to find the problem in that the protagonists were actively hiding their involvement in any incidents. The two people involved were having an affair and the static was caused by the ladies lingerie and the work bench.


Gives new meaning to the word “brownout.”

1 Like

3 posts were split to a new topic: Genre filter not showing NRfY

I have been having remote issues on my One Plus 5 phone since since the Android refresh and with the latest remote it’s worse . Core and everything else is fine as is windows remote.

ROCK on Cirrus7, Roon Control on MBP (macOS 10.15.3), iPhone and iPad (iOS 13.3.1): not the faintest glitch :slight_smile:

How have users managed to update their iPads to 521? Mine is still at 511 so I still can’t do it and hence have no Genre tabs in NRFY.

just wait: took a couple of days for the update to show up on the iOS App Store

My iPad updated today. Check the App Store again and I’m guessing you’ll see the update there :wink:.

1 Like

I have no issues at all after upgrading:

  • Core: ROCK on NUC (NUC8i7BEH)
  • Roon Bridge: Allo USBridge running DietPi
  • Remote: Windows 10, 2 x iPads (iOS 13.3.1)

Had some odd behaviour (skipping through tracks) when I first turned it on but seems fine now.