Allo DigiOne - cracking and popping noises


Just assembled my raspberry pi 4 + allo digione setup, connected it via roon and to my disappointment I keep hearing those annoying cracking/popping noises every 2 seconds or so :frowning: The noises do not appear when I listen via my macbook’s usb port or via the macbook’s headphone output, more details below. Anybody experiencing the same? Can it be fixed? Is fo, how do I go about fixing it?

  1. Does not work (annoying, very audible, frequent cracking/popping sounds):

    macbook pro -> roon + tidal hi-fi -> raspberry pi 4 + allo digione -> coaxial spdif -> xduoo xa-10 dac/amp -> headphones
  2. Does work (clear sound, no cracking/popping sounds):

    roon + tidal hi-fi -> macbook pro's 3.5mm headphone output -> headphones
  3. Does work (clear sound, no cracking/popping sounds):

    roon + tidal hi-fi -> macbook pro's usb output -> xduoo xa-10 dac/amp -> headphones

I tried various asllo digione settings in roon, but none of the combinations I tried worked, so just went back to the defaults.

What’s your network look like? What DAC are you using?

What OS are you running on the Pi 4?

More details are needed here :slight_smile:

Thanks for your response.

  1. network - I have the raspberry pi + allo digione connected directly to my router via an ethernet cable. Could try a different cable maybe.
  2. My dac/amp: xduoo xa-10.
  3. OS: latest ropiee (2021/07/21, the regular one, not xl)

I assume as you have the Allo Digione that you are using a coax connection

Have you tried the USB direct out of the Pi ?

If you are using USB , reverse the question

@spockfish may be able to help if he has experience of the dac

Forref, the reason I use the Allo Digione is to get a coax supply, my Audiolab MDac has problems with USB

Thanks for the response. I will give the USB a go (still getting used to the setup) and will get back to you. For now I can confirm I’m using the coaxial connection between the allo and the dac/amp.

Cracking / popping can be loss of data either network or something going on within the I2S interface (or a faulty SPDIF board).

The USB suggestion is a good one to eliminate if it is network (if USB works its not network).

Next would be new coax cable and sometimes you can get impedance mismatch which can cause data errors.

The other thing to try is increasing the buffer:

Buffer Size (WASAPI and ALSA only)

This setting allows you to tell Roon to request a specific buffer size from the driver. There is no guarantee that Roon will get the size you ask for, but it will try to choose the closest one. In theory, all devices should be willing to accept any buffer size, but this is not always true in practice. Larger sizes aren’t always better! We get the best results in the 25ms-100ms range.

I’ve seen (heard) this problem on the Allo with some Linux kernels. I’ll see if i find my script for rolling back to a known good kernel. Sadly, latest is not always best.

Have you spilt milk on it…snap, crackle and pop. Sorry I just couldn’t resist.

I have a Pi4 with the DigiOne HAT, via coaxial I have not noticed this. I’d take the Pi4 and HAT apart. Ensure no dirt or grease on pins. Ensure assembled with bridges between the boards. Swap power supply (brick and cable). Also worth a try is Volumio, which I run. Also, try a different coaxial cable.

Do you have another streamer you could connect to you DAC/headphone amp to eliminate these.