Allo DigiOne Pi4 Ropieee endpoint dropouts but iPad endpoint OK?

Hi - I have a weird one, since changing ISP I now have a big white Nokia router and I am finding that wifi is not so good as before. I am getting dropouts continuously in Roon. So I tried using the iPad as a endpoint instead of the Pi and low and behold no dropouts? This is weird as on my old wifi network was fine, but now the Pi seems to be very picky? We have tried separating 5Ghz and 2.4Ghz networks as I am in flats and very congested, but connecting to 5Ghz hasn’t helped.

My old wifi router was a TP-Link Deco M4 Mesh, I didn’t use the other mesh unit as there was no need, the one hub was plenty powerful enough to deal with the entire apartment. Now it seems the iPad can connect ok without issue but the Pi not so… has anyone had problems with Pi4 wifi connection I wonder?

PS. I would like to put the Nokia into bridge mode and connect my TP-Link again, but Jurassic Fibre my provider can’t make it work, it just won’t connect to the internet via any ethernet port no matter what credentials we put in for access. I can’t access the Nokia directly to investigate as there is no login, it has to all happen via their end and takes 24 hours to action.

This is not so weird :wink:

Having WiFi properly working on one device doesn’t say anything about the same WiFi working on another device. Lot’s of stuff involved…

The Pi WiFi is capable, but it is a small device without an external antenna.

And a ‘general tip’: if you can, try to stay away from routers provided by an ISP but I guess you already experienced that… :wink:

If you send me feedback (you can find that option on the advanced tab) I can have a quick look.

Thanks for the response Harry, I’m negotiating with my provider at the moment to replace this router or at least to allow me to use my wireless router and get my old Wi-Fi back! I’m sure nothing has changed on the Pi, I had this issue years ago with an old Apple AirPort Extreme but it went away when I got the TP-Link mesh network and stuck my BT router into bridge mode, but I can’t get into this one so I have to wait for an overnight reset… not ideal!

1 Like

Tim, as an alternate approach, many modern routers allow other routers to connect to them. I do this with my AT&T router which is required for my fiber service, but I then connect an ASUS Ai mesh network to one of the ports and run all my traffic using the ASUS system. The only change to the AT&T router is to disable its WiFi so it does not interfere with my ASUS equipment. Can you try that with your Deco M4 system? You may also need to supply a different IP address range for the Deco platform. ASUS defaults to 192.168.50.x for their system, but I applied my own range without issues. Not sure what TP-Link does.

Hi Robert - thanks, yes we managed to organise exactly that yesterday, and indeed I now have a stable WiFi with my previous Deco network restored… except… just turning off WiFi but without setting the host router to ‘bridge mode’ the Deco system creates a new IP subnet. So the LAN is 192.168.1.??. and the WAN is 192.168.68.??? - everything works fine except Roon! :triumph:

Apparently Roon requires all endpoints and devices to be on the same subnet… why who knows, everything else manages just fine!

Tim, yes, Roon requires all connected devices to be on the same subnet as it was designed this way.

I set up my network so that my ATT router, which defaults to 192.168.1.x provides the addresses, and then assigned my ASUS IP for all of my LAN connections. My ASUS router then provides DHCP to my LAN connected devices.

Are all of your wired and WiFi devices connections connected only to the Deco now? They should be connected to the Deco’s WiFi or Ethernet ports, and you should not really be using the service provider router except as an upstream connection to the Deco. That way the Deco’s subnet will be your LAN and Roon and any other devices connected to the Deco’s LAN should now work.

1 Like

I had the same problem my ISP demanded their “little blue router” so they could have access for diagnostics. I simply run one of its Ethernet ports to my router, job done.

Funnily enough the VOIP doesn’t work from my router but does from theirs , so it has its uses

Glad you came right


@Robert_F @Mike_O_Neill

Hah! The solution!! :smiley:

So I had all the ethernet cables into the ISP router, and one out to the Deco wifi router (because it only has two ethernet ports). Now I have brought back into service a cheap network switch I used (before the ISP router arrived with all its ports), connected all LAN devices to that, connected that to the Deco wifi router and the Deco router to the number one port of the IPS router. So now the only thing connected to the ISP router is the Deco using it as a means to get to the internet, all devices LAN and WLAN are now delivered by the Deco unit and all belong to the same subnet… phew!!! :star_struck:

Plus… whilst testing my now restored full Deco network I notice the album I have been using as an example still has dropouts! SO it was this all along!!! :crazy_face:

This album is the only one in my library at 24bit 176Khz, it is served by Qobuz and I have checked, all other bitrates are fine, right up to 192Khz? So I’m now going to check other 176Khz on Qobuz and see if something in my chan has an issue with this bitrate? It might be just this album… if anyone has Qobuz and fancies checking it is Rachmaninoff: Symphonic Dances & Vocalise - Respighi: 5 Études-tableaux After Rachmaninoff - Eiji Oue.

Still I have a far more robust wifi network back now regardless, it is very easy to interrogate, it tells me when new devices connect, I can see IP addresses easily, set parameters and add mesh units here and there of required! Bye bye Nokia router wireless… :blush:

Thanks for the all the help guys… you sorted it before the ISP even had time to get me into bridge mode remotely again!

1 Like

Glad you’re back in business Tim, your network configuration is correct for creating the subnet. Keep us updated on the 24/176 file issue too. Have fun.

1 Like

Ok reporting back! :blush: After significant searching I managed to find another Qobuz 176Khz album (by the same conductor actually) and sure enough there are significant dropouts immediately.

After much testing it seems either the SPDIF coax output of the Allo DigiOne is at fault or my little Soncoz la-qxd1 has an issue with this format on the SPDIF coax input. USB from the Raspberry Pi direct and from my iPad (via Lightning/USB converter) is fine, its only coax from the Allo that seems to be an issue?

One interesting side effect of this is I’m finding it very hard (on headphones critical listening) to distinguish between USB straight out of the Pi4 and coax from the Allo DigiOne HAT - I feel it is a tad lighter and transparent… but truthfully that may be my own bias! :blush:


Glad you’re sorted , I was always suspicious of why the ISP needed that Router – BIG Brother :sunglasses:

1 Like