Allo USBridge board

Sounds perfect except that option isn’t exposed on the C52 :frowning:

EDIT : I just saw the thread in support showing other folks have the issue with Dietpi…

Anyone else having an issue updating to Version 1.0 (Build 167)? Roon says the update is downloading & installing but then states ‘There was an error checking for an update’.

I’ve tried uninstalling the Roon client in dietpi and reinstalled but still it shows the previous version of 164 and then attempts the same cycle as above.

Just performed this, without any issue…
(On my USBridge with DietPi, clean install)

This was not true, sorry bout the confusion. The install seemed to do fine, but the version number never changed. I too have manually installed.

All my ropieee bridge installs updated to 167 no issue, but all my dietpi sparky x2 and a rpi are stuck at 164 still

I have this exact same thing @Mike_Ormerod and @wizardofoz , did either of you find a way to solve it?

I manually updated.

Thanks, I did too in the end.

@CrystalGipsy

please could you describe me exactly how to use Qobuz and Spotify with the USBridge ?

thanks.

Hi @erho no problem. You need need to be ok with Linux and ssh to do it. First you need Diet pi installed as the operating system, this came as standard. You need to ssh into the device and then from dietpi-software menu install Raspotify and you also need MPD Music Player Daemon.

Raspotify is for Spotify connect…You need to change a few things in Raspotify settings file to get the high quality stream and that’s about it. You need to look up it’s location in Dietpi.cant remmebr off hand as I don’t use the bridge anymore. Main instructions here about it you can ignore the install as dietpi does it for you. https://github.com/dtcooper/raspotify/blob/master/README.md

MPD is a player software that will help you play Qobuz but you also need to install a upnp client called upmpdcli which works with it.

https://www.lesbonscomptes.com/upmpdcli/downloads.html.

You dont need to change much here if you don’t want to and you can ignore the bits about Qobuz and Tidal as you dont need them as you can use a phone app for that bit.

Get either Kazoo or Lumin app for your Phone, these will see the upmpdcli as upnp renderer to play to and they have accees to Qobuz in then you just need to add your credentials.

Thank you @CrystalGipsy

One question, over night is it recommended to shut down the device or to leave it on permanently?

Hi Eric,

I definitely would leave it on all of the time. Power draw is minute (on the order of 1.7 watts), and digital gear tends to work best when left on for 24-48 hours at least anyway.

Pro tip…I’ve found that the USBridge sounds a bit nicer when an iFi Audio DC iPurifier2 is connected in-line with the provided 5V power supply. I’ve tried separately powering the Sparky board using a high quality 5V DC source; however, I’m not sure that this improved the sound further.

1 Like

Glad that I found this board though…I have been using the USBridge (DietPi + Roon Bridge) for nearly a year but do have a question. I’ve observed that when I have one of my iFi Audio DACs directly connected to my Apple MacBook Pro and stream MQA, the Signal Path shows more complete information, including the “MQA Renderer ORSF” sampling rate and “Analog Output” stages. This information is absent from Signal Path when streaming to an iFi DAC that is connected to the Allo USBridge. Here’s a simple example:

“Loft Sparky”, of course, is the name of my USBridge. Although Signal Path shows that the iFi USB Driver is recognized, the ORFS Renderer information is missing on the USBridge. Before you ask, I verified that the settings were identical for both zones: “MQA Capabilities” set to “Renderer Only” and “Enable MQA Core Decoder” set to “Yes” for both. In this instance, DSP and volume leveling are disabled for simplicity:

The options are a little different for MacOS vs. Linux/DietPi, but as you can see, they are essentially identical, yet the signal path (above) is not. What is especially curious is that the Signal Path on the MacBook Pro is flagged as “Enhanced” while it’s “Lossless” on the Allo USBridge. I assume this is because Roon is not trying to guess what happens after the signal is received by the ALSA driver? Not sure. It’s also strange that Roon Core has to work a bit harder in the MacBook Pro case than for the USBridge (note the “Processing speed: 18.2x” for the Mac case yet absent for the USBridge case).

Here’s another example with my more typical settings…DSP and volume leveling enabled and identical between MacBook Pro and USBridge. In this case, Signal Path is “Enhanced” for both, as you’d expect:

I’m not really worried about this…as far as I can tell, the iFi DAC is rendering the MQA stream the same way in both cases. It would be nice; however, if iFi and Roon would work together to properly add the iFi DACs to Roon’s database so that the graphics show up and the signal path is complete for iFI DACs that are connected via the Allo USBridge.

BTW, I have tried manually identifying the device as Allo USBridge (does result in the correct graphic for the Allo) and then manually overriding all of the settings so that they match what I’ve shown above. No change in the signal path though…MQA Renderer ORFS and analog output are still missing. I’m interested in hearing from others who may have similar configurations, and especially from Roon and iFi about possibly adding these DACs as first-class citizens. I’m happy to help with testing!

2 Likes

Rebooted my USBridge this morning and now no matter what I do Roon doesn’t see the USB output :frowning:

1 Like

Check it shows up in the os it might have died or lost it as the main audio device in deitpi. Mine started to do this and that it died permanently.

Ssh in and go for dietpi-config and choose usb-dac and reboot via the shell.

Hmmm, that might explain things. It’s showing soundcard as none (even though the GUI showed usb-dac), but now I can’t select usb-dac when I ssh, it attempts to set it and just drops back to the menu with the soundcard still as none. I wonder if the board has died :frowning:

It looks like a quick error message displays but it’s too brief to read. I wonder if there’s a log file someplace.

I would drop Allo a line to see what they say. You can also ask @allo.com

I’ve already emailed them. Thanks.

After the last DietPi update, I couldn’t get USBridge to work with the Allo GUI. When I reflashed the eMMC card with the non-GUI DietPi image, USBridge has been working fine.