Allo USBridge board

In case it’s useful to anybody else, I tried @Fernando_Pereira’s earlier suggestion to:

apt remove alsa-utils

That worked, no more amixer trouble on reboot and Roon Bridge works perfectly. It would be great if Roon Bridge did not bring in all that unnecessary ALSA utility cruft.

It didn’t work in my case. USBridge disappeared from Roon (perhaps because I have no other audio applications in DietPi, except Roon). I then did:

dietpi-software reinstall 121

and all is well.

Similar complaints to you, Wouter – USBridge to a Rotel RC1590; sometimes it’s there, sometimes it’s not. Have to power cycle to make it reappear. Which is a shame, because I really love the way it sounds.

Haven’t investigated in the OS, but may do so, to see if same results as you.

Note that I have the Rotel set to turn itself off after 5 hours of idle time.

hi, when you turn off the mojo you first stop the music in roon? or you just turn off mojo suddenly? because I realized that if i turn off mojo without pausing the music the system stop recognizing mojo and then i have to reboot.

Hi Adrian,

Thanks for the suggestion, but I do pause the music first before turning off the mojo, and I am having the same issue even on Dietpi 6.9.

It looks like the USB subsystem is having issues, as I can not disable the device at that stage, and it also causes soft reboots to fail.

Hi gents I don’t know if any of you have seen this post, it may or may not help: DietPi + Allo Web GUI: Now available:

Hi @Phil_Knowles

possibility: Dac alone power off during Music play, this case USBridge USB port locking with player.

you can do SSH login and nano /DietPi/uEnv.txt aotg.urb_fix=0
note : edit this only for ROON, Roon+ HQplayer this parameter need to set 1

You may already have solved this, but let me know if you still have questions or concerns about rehashing your USBridge with the latest DietPi. It was not terribly difficult and still sounds great after the update. :slight_smile:

Has anyone tried powering the Usbridge by a powerbank? Maximum battery amperage I find is 2.4A and Usbridge spec is 3A. I keep CPU Governor at Max Freq 720 MHz, so power requirements might be lower? Any experience? I wouldn’t want to damage this wonderful endpoint, for sure.

Btw, I’ve tried a powerbank (TP-LINK 5200) to power Sparky (with Allo PSU for Usbridge) and think it sounds purer, similar to less jitter. So I’d like to try it on Usbridge,too, hence the question.

Accordign to the description of the Allo USBridge, the Sparky is the “power hungry one” and it is possible to power the two boards separately removing the jumper.
The Sparky can be supplied with the stock SMPS, and the USB card with the power bank.
Power first the USB card, than the Sparky board.

1 Like

Thanks but that’s not correct.
According to Allo, “Please note that you can feed the Sparky separately with one PSU (5V / 2.0A) and USbridge HAT (5V / 100ma + whatever your DAC needs).”

@RBM’s configuration: “The USBridge is powered by a 5V/3A Sbooster LPSU; the Sparky is powered separately over USB by an old iPad PSU.“

Usbridge power requirements:

microUSB (Sparky) 5V/1.8A
DC (USBridge) 5V/3A

A USB HAT requires enough power to run it plus the potential to power a device downstream.

I should perhaps have made it more clear that I’m talking about powering the two independently.

Thanks - I contacted Allo and they kindly sent me a flashed card which I installed and returned the old one to them. They were very good in this respect.

2 Likes

Hi Phil,

How is things your end with Dietpi 6.9? I haven’t experienced the same issue with my Mojo since updating to Dietpi 6.9.

I do have aotg.urb_fix=1 set in /Dietpi/uEnv.txt as @rahulkc_s suggested.

1 Like

I made the change last week, but have been away since so will let you know when I get back.

Hello Allo Team,

i’ve got a USBridge with DietPi Allo Gui and use it with my iDSD micro. I sold the iDSD today and ordered a Mytek192 DSD.
Did the USBridge support the relatively old Mytek192 DSD with the installed DietPi Allo Gui?

Thanks and many greetings
Dominik

Mytek 192 DSD not tested with USBridge, On googling got info that this model required separate Driver and firmware.

Hi @Wouter_du_Toit…since making the changes some 4 days ago, everything seems more stable and not having to reboot to recognise the DAC every other day. A promising sign…

1 Like

Just got the LPS I ordered of the well known auction site and using itsDC and usb outpus to power each board. Its opened up a bit more, Bass has a bit more depth to it.

One thing Roon does not seem to recognise my DAC can do native DSD so I get all the encapsulation options.
Not sure if Roon is the issue or DietPI not giving the correct info back to Roon. DAC is Arcam irDAC ii.

As per the other thread your dac can only do native dsd on windows so there lies the problem.