Almost impossible to "Add to tag" more than 99% of the Tracks that are in "My Library"

Core Machine (Operating system/System info/Roon build number)

Mac mini (Mid 2011), 2,3 Ghz Intel Core i5, 4GB RAM, Intel HD Graphics 3000 384MB, 121 GB SSD (99,5 GB available), macOS High Sierra version 10.13.6, Roon version 1.8 (build 778) stable. The Mac mini is used as a core for Roon only. There is nothing else running on it.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

broadband internet, wifi connection to core, wifi connection to endpoint (Bluesound Node 2)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Node 2 > coax > Topping D70s DAC > rca > Roksan Kandy K2 integrated amp

Description Of Issue

Problem: it is almost impossible to “Add to tag” more than 99% of the Tracks that are in “My Library”.
Some examples:
(1) I go to a Playlist. All of the tracks of the playlist are in My Library (I double-checked). When I want to “Add to tag” a track (after hitting the three dots), this is not possible for more than 99% of the tracks (I can “Add to playlist”, I can not “Add to library” (which is light grey), neither can I “Remove from library” (which is not shown).
In the less than 1% of cases where I can “Add to tag”, I can also “Remove from library”, and in the column “Date added”, it shows a date. For all the other tracks it does not show a “Date added”. I tried to add the entire album of the tracks to My Library to see if that makes any difference. It does not, at least not when I am in the Playlist. The interesting thing here is that in some cases it is possible to add a track to a tag from within the Playlist menu. What makes the difference? See PS below.
(2) I play a track that is in My Library. I try to “Add to tag” (by hitting the three dots). Same as with trying to add from the Playlist menu: most of the tracks: not possible to add to a tag (or remove from library). A very limited number of tracks (the same as in the Playlist menu): perfectly possible after hitting the three dots.
(3) I go to History and try the same thing: “Add to tag” a track that is already in My Library (I double-check if it actually is in My Library). In the History menu, a similar problem occurs: most of the tracks that are already in My Library can not be added to a tag. But there is a difference. When the entire album on which the track is, is also in My Library, then I can “Add to tag” from within the History menu.
(4) I “Add to tag” an entire playlist. When I go to My Library > Tags and I select the playlist tag, less than 1% of the tracks that are actually on the playlist are shown. Those are the same tracks that have a date in the “Date added” column (the ones that I could tag from within the Playlist menu).
(5) Finally, when I go to My Library > Tracks, I can “Add to tag” any track I want, also the ones that I can not add from the Playlist and/or the History menu.

What I would like to know: how can I make sure that I can add to a tag from the Playlist and the History and the Now Playing screen all the tracks that are in My Library? What am I doing wrong? What am I not understanding here? This is really important for me. Roon only makes sense for me if I can use it in an efficient way to better organize my music using a combination of Playlists and tags.

PS: In a further effort to understand what is (not) going on, I discovered that the tracks in my library that can be tagged from anywhere (playlist, history, now playing), are:

  • either the ones that I have added to my Tidal collection on January 12, 2021, that is the first day of my four-month Tidal trial subscription… All tracks that have been added later seem to suffer from the same problem that they can only be tagged starting from My Library > Tracks.
  • or the ones that are on the HD with my own albums.

For all other tracks the tagging functionality seems to be flawed (possible only from within the complete track list, not from the playlist, history or now playing screen). This is even true when I play a Tidal track in Roon and add it to my library. I can not add a tag unless I go search the track in the complete track list.

FYI: On the home screen it says I have 8360 tracks in My Library. A small part of them is on hires rips of albums I have on an external HD connected to my core. Most of the 8000+ tracks come from Tidal (where I favored all the tracks in my Tidal playlists before making a local copy of those playlists in Roon). Most of the playlists and tracks in Tidal have been transferred by me from Spotify using Soundiiz. I forced a rescan of my Roon library to see if that made any difference. It did not. I also tried restarting the Mac mini core. No difference either. And I tried making a new local copy of a Tidal playlist (in which all tracks had been favored in Tidal). No difference.

I hope you can help. I spent a lot of time searching the knowledge base and the community forum, but could not find an explanation or a solution for this issue.

1 Like

With some much-appreciated help from @anon90297517, I think I figured out why it is so difficult to add a track to a tag. Basically: you can only tag (the version of) a track that is in your library.
If you want the full functionality of tagging, you need to proceed as follows: (1) always start by putting a track in your library, (2) never assume that if (immediately) afterward, you want to tag that track or put it in a playlist, that Roon will be aware that it (obviously) is the library track that you want to put in the playlist or add to a tag, (3) instead, go to My Library > Tracks, find the track there and put it under whatever tag or in whatever playlist you want. After you go through this hassle, everything will go smoothly…
A related issue. You have a Tidal subscription. You have plenty of playlists on it. You read in the Roon info that tracks that have been favored in Tidal will automatically be added to your Roon library. So, before making a local copy of your Tidal playlists, you make sure to favor all tracks on them in Tidal. And yes, it is true: subsequently, all those tracks can be found in Roon under My Library > Tracks. One big BUT: in the (Tidal) playlists you make a local copy of, it are not the library versions that can be found in Roon, but the Tidal versions (if you have the column ‘Date added’ in your playlist screen, you will see that it is empty). Which means that you can not tag the tracks in your playlists, because technically they are not in your library (although an exact same copy IS in your library).There is a solution for this: replacing every single track in your playlists with the same track that you can find under My Library > Tracks. How do you do that? Simple! One by one! Cheers!
Of course, if a Roon staff member or anyone else knows a better way, please let me know!

1 Like

I tried to put this issue into a broader perspective in this feature request: Solve the library/non-library conundrum and all the complexities it creates for tagging, focus, playlists etc