Amp2 and HQ Player volume

Hi Everyone,

I’m sure this is rudimentary, but I’m using HQ player on a PC with Roon core, with a RPi4/Amp 2as NAA endpoint. The Amp2 has no physical volume control and I would normally control volume in Roon when not using HQ Player. I set the min volume in HQ Player to 0db and max to 60db. I can control the volume using the slider in Roon but it’s incredibly quiet, even at 60db and I’m not sure what I’m missing. Fixed volume doesn’t solve it, I’ve turned on the 6db gain in the DSD settings in HQ Player even though I’m only outputting PCM, and there’s no DSP enabled in Roon. Any help is appreciated!

Set min to -60

Set max to -3

Start music at -60 and slowly increase until you know what your normal safe range is.

For your first time maybe even wear earplugs to protect your hearing.

Maybe share a bunch of screenshots so we can see all your HQP settings and Roon settings and signal path.

It makes it easier when we see what you see. Otherwise it’s difficult to solve.

Here’s the relevant information, @dabassgoesboomboom. With the volume in Roon all the way up, as pictured, it’s barely audible. I should add that this is the case when I output directly from HQ Player as well.

I don’t use HQPlayer Desktop version (I used Embedded version) but in the background of your screenshot I see the volume knob is red. That doesn’t look normal.

Can you show that screen?

@dabassgoesboomboom it isn’t always red; that’s one of the things I’m trying to pin down.

I re-flashed my RPi4 micro SD card and then turned off the force volume feature when setting it up again. Between these two actions, the issue is resolved. Of course I wasn’t expecting the volume to work as expected and had it cranked when I first played to it following the reflash…

1 Like

I did try to warn you !

But hopefully it was just acoustic guitar that came on, not Metallica

Haha, Black Sabbath to be exact.

1 Like

@dabassgoesboomboom This issue has returned. I haven’t had a chance to play much the last few days and today the volume is barely audible at-3db again, no settings change from last week when I was testing and reported it as resolved. I’ve done everything I can think of (Force Volume was never enabled tis time around) short of re-flashing the card again. Can you think of any reason this may be happening or how to fix it? Every piece of hardware has been fully power-cycled…

Can you share a screenshot of all your RoPieee settings.

This force volume thing (in RoPieee) should never be touched for Roon or HQP.

Just wondering what your other settings there look like?

A screenshots of all your Roon and HQP settings again.

Do you get the issue if you set upsampling limit to 96kHz?

@dabassgoesboomboom Force Volume wasn’t touched touched since the re-flashing last week and is still off now. Switching to 96kHz made no difference; attached are the screenshots.

All settings look very good.

When you say volume is barely audible at -3dB , you can hear the music or it’s actually silent?

@dabassgoesboomboom I can hear it sitting about a foot from my speakers. When it was “normal” after reflashing the SD card last week, I never took it above half volume and was sitting about five feet from the speakers, so I feel like I have baseline for what I’m supposed to be hearing.

1 Like

You’re definitely turning HQPlayer’s volume up?

Got a screenshot of HQP volume knob?

When you turn it down to -60 does the volume actually reduce? (change)

And going up from -60 you can actually hearing it change?

@dabassgoesboomboom yep, I can hear changes - it’s all relative to how quiet it is at the max volume, though.

There is likely software controlled volume for the output device. You can set the output volume using “alsamixer”. If there are multiple output devices, you can list those with “aplay -l” and then use the card number with -c argument to the alsamixer like “alsamixer -c 1”.

You can then store the volume as default for startup using “alsactl store”.

P.S. I don’t know much about RopieeeXL, only about my own NAA OS image, but I assume this is similar.

1 Like

Can ask the RoPieee Guru @spockfish to see if he can help @Tyler_Kemp ?

Note that if one is running HQPlayer Embedded on Pi4 directly, without a NAA, it is possible to configure HQPlayer’s volume to control both the software controlled hardware volume and HQPlayer’s internal digital volume in a combination way. In other cases HQPlayer leaves any hardware volume alone and expects those to be set outside of HQPlayer scope.