Android app having trouble finding Linux Core

Just to let you know you are not just chasing a ghost. I have a Note 3 with Android 5.0, a Note 4, Tab S2, Galaxy S6 and Galaxy S7 edge; all connect to either my ROCK NUC or my Win 10 server. Don’t have connection issues with any of them.

I just updated all of them to verify in case an update had caused issues, as I don’t use some of the older ones all the time. I do use them as mobile endpoints though and they work well for that.

I am pleased for you, but some of us are having connections issues with Pixel C, Z3 Compact, Z3 Tablet, Z4 Tablet, so no ghosts here, just constant reboots of the server to get connection.

So here’s another interesting thing. I was doing some more trouble shooting. Started with the usual things clearing cache, clearing data, forcing stop, and then finally reinstalling the app. This seemed to help the Pixel C some but the Note 3 not at all.

I also went through a house cleaning on my router getting rid of all the old entries for devices and computers I no longer have (mac filtering). I tried tuner things on turning things off (too long a list to put here). Nothing seemed to help other than when the setting forced a reset of the communication to the devices. It was also not 100% consistent with the way it responded to the changes.

Then I thought about the different setting available fo the apps in app manager and elsewhere on the devices. Like notifications and permissions. I shut notifications down for the app on the note 3 and bang it works now (mostly, still not 100%). I tried it on the Pixel C and sure enough it works much better. Lots of starts and stops of the app so the percentage is pretty high of working connections (still not all the time though). Oreo has a few more options for apps than 5.0 so on the Pixel C i also took away the permission for accessing my contacts from the ROON app, that seemed to help a little but i think it is the shutting down of notification for the ROON app that made the biggest difference.

I know very little about what this really means and for all i know it just magically works now, But I did turn notifications back on and it seemed to get worse. Not sure if this helps any or not or just muddies the water a little more.

Thanks I will test this and see if it makes a difference for me also.

Also when I went in and changed the settings for the Roon App I got a warning message saying:

“This app was made for an older Android version and might not function properly”

Did you also get that when changing the “rights” of the App?

Yes, I did see that message. Also got the error about the app might misbehave if I take the permission away… but it is already misbehaving so…

Hey folks,

Wanted to provide another update as we continue to try and understand the conditions under which this issue occurs.

As I’ve mentioned previously, no one on the Roon team who uses Android has ever seen this issue occur in their own homes, nor have we heard it reported by any of our 40+ alpha testers.

Rough estimates are that this affects less than %1 of Roon Android installs, and I say all of this to be clear why we are having such a difficult time making progress – it’s often extremely hard to reproduce and resolve issues without reproduction steps that consistently trigger the issue in a debugging environment.

We had some hope that this issue might be resolved in Android 8.0 but all signs point to this persisting even when running the latest pre-release versions of Android.

Our testing continues, and so I wanted to provide a few updates here.

  • We have noticed that an inordinate number of affected users are using Ubiquiti networking gear. For those of you in that group, it would be a hugely helpful test to see if things are better with that hardware temporarily removed from the network.
    Ideally, for that test you would be running a total of 3 devices on the network:

  • A simple wifi router with default settings

  • The Roon Core

  • The Android device
    If things continue to fail in that configuration, we would like to know.

  • While we don’t currently have a good theory on why this would only affect some configurations, it would be great if everyone could get into this broken state, and then try disabling the Android device’s mobile connection by enabling Airplane mode and then turning on Wifi – we are wondering if multiple network connections could be related, so this will also be an interesting test. If possible, it would be great to run this test in the simplified configuration I mentioned above: wifi router with stock settings, Roon Core, Android device. We know that won’t be possible for everyone, but that would be our recommendation for a truly “clean” test.

  • Finally, we are designing some more intensive tests that we would like to run early next week on some of the affected setups/networks. These tests will require us to coordinate a time to run the tests, and will likely require the user of some additional logging we have in place in ROCK, as well as the ability to run a simplified network as I described above. If you are experiencing this issue on ROCK and think you’d be willing to work with us to run some of these tests, please drop me a PM and we’ll coordinate a time.

We are not giving up here folks, and neither should you. We will keep at this until we have resolved the issue, and I want to say one more time how much we appreciate everyone’s patience – this is one of the trickiest issues we’ve encountered in the history of the company, and we’re as restless as you guys (if not more) to close it out.

We’ll get there. Thanks everyone!

6 Likes

Unfortunately, my Ubiquiti-based network is deeply baked into my hardwired-into-the walls home network and I don’t have any other wifi APs (the Unifi AP Pro is the only one I tried that works reliably in my very crowded wifi neighborhood, so I got rid of everything else). However, I’m happy to mess around with router or AP configuration parameters.

I don’t have the Ubiquiti stuff you are looking for. I did try the airplane mode thing and it seems to help jog the system into connecting. I have also tried removing most of the other WiFi over to wired or just shut them down for a while, to reduce the traffic.

Thanks for the feedback @bearFNF – the Ubiquiti stuff is notable because it’s come up more than we’d expect, but there are a good number of people affected who are not using that hardware.

As always, it’s possible we’re looking at multiple issues here with different causes but similar symptoms :frowning: @Eric is going to follow up with you to get some logs, in case there’s some useful information in there. Is this pretty consistent:


@Fernando_Pereira – thanks, and understood about the network. I assume you’re not having any change running in Airplane mode with wifi in?

2 Likes

Yes, it did seem to be pretty consistent. Let me see if I can break it again see what happens. I mean set the permissions and notifications back to default and see what happens with the connection and if it breaks try the airplane mode thing again.

For logs is there process for “starting point” I should do to get clean logs? in other words should I purge and start new ones? Just trying to see if there is a way to simplify the “search” in the logs…

Edit: just sent he logs in from my Note 3 running android 5.0

1 Like

Tried airplane mode with wifi on last night, still no core connection. I’ll do more careful testing this weekend, though.

1 Like

Flipping on airplane mode and then connecting to only Wifi does not allow my remote to find the core.

@Fernando_Pereira and @Michael_Taormina did either of you try turning off notifications and modifying permissions for the ROON remote app? That seemed to help my issue…FWIW

I did also turn off notifications for the Roon app and remove permissions to contacts for the Roon app, no luck.

1 Like

well shoot, was worth a shot… your issue may not be exactly like mine then I guess. How about reinstalling the app? Did you try that, also?

I completely reinstalled Android two days ago and have reinstalled the app itself many times on multiple devices.

1 Like

Yes, tried all that + airplane mode, no luck.

2 Likes

I’m having trouble connecting with my Pixel since moving to 8.0 yesterday. It used to run perfectly on 7.1.2

Yesterday, after around 30 minutes it connected and I deleted my original post here. However today, I have the same problem.

All my other Remotes (PC, iOS, macOS) work perfectly.

That is not what I want to hear! My Pixel C has been flawless up until now. I haven’t been offered the upgrade yet.

I wouldn’t worry too much, as the issue was/is present for devices all the way bask to Android 5.0… Not sure that it is Android version related…but until the issue is nailed down…who really knows.