Android app having trouble finding Linux Core

Where are we with this?

Still unable to use my android phone as a roon remote after many many months

Did you try to configure your home network without IGMP snooping?


I have IGMP proxy turned off on my router WAN tab, which I think is the same thing

By no means an expert on IGMP, but I don’t think WAN IGMP proxying is the same as LAN-internal IGMP snooping.

Am sure you’ve probably been round the houses with this but it’s worth mentioning that there seem to be a bunch of different things that can lead to the same error message. On one controller I found it was down to flaky wifi on that device (it only worked reliably on low 5Ghz channels). On at least two others, running two different Android versions, I’ve found that ensuring it was exempt from battery saving proved to be the solution. Personally I’ve never found it necessary to disable IGMP snooping but this seems to work well for some users, as @Fernando_Pereira mentions.

I’m sure I read on a message somewhere that, for a particular router, igmp proxying has to be on for things to work. Seemed to be a bug in the router - may be worth toggling it, rebooting the router and seeing if it makes any difference?

Edit: See Repeatedly losing connection to iMac Roon Core


I am new to Roon and also unable to get either of my Android devices (a Pixel XL running 8 and a Nexus 9 running 7) to connect to my Roon Core. The Mac and Windows desktop clients, however, connect without issue. As I am new, I am starting off at Roon 1.5 and the Core version is shown as up to date when viewed from one of the desktop clients. The Roon Remote app is current and obtained from the Google Play store.

I am running Roon Core on a CentOS 7 system. firewalld is disabled; there is no host-based firewall running on the Roon Core system. While the Core is connected via Ethernet (it’s running on a Dell R230 so has no Wi-Fi hardware), it is in the same VLAN as the Android Wi-Fi clients. The OS is running bare metal, not virtualized.

Launching the Roon Remote app just gives the “looking for your Core” screen. If I click the Help option and directly enter the IP address of the Core system, it still does not connect; it just spins indefinitely. I see comments about disabling IGMP snooping in this thread (which shouldn’t be necessary if the Roon client and server are both properly calling the OS’s functions to join the multicast group), but I assume that specifying the IP address of the Core server should result in bypassing the auto-discovery entirely, and just send direct unicast to the Core server. Or is that not the case? (Regardless, disabling IGMP snooping is not an option. And everything else I have that uses multicast for discovery works fine.)

FWIW, the network is all enterprise gear: MikroTik CCR for the Internet router/firewall, with Meraki switches and Wi-Fi access points internally. Topology from client to server is: Android Client -> Access Point -> Distribution Switch -> Core Switch -> Roon Core server.


Well well well …

Turned on IGMP proxy (not sure if this includes LAN snooping or not, as there is no separate setting) and lo and behold it all works again !!

Thank you for the tip

Excellent, glad to hear it :grinning:

I hesitate to post this but… so far my problem seems to have gone away.
In preparation for a Lumin replacement for my Node 2, I installed a wired connection to my streamer - the Lumin cannot use Wi-Fi like the Bluesound. The Node 2 switched over to using the wired connection without problems and I left everything else unchanged while I awaited the Lumin. This was about a month ago.

It suddenly hit me that I have not had any problems losing the core since. Strange, I used to get the problem once or twice a week and could only fix it by rebooting my remote (Samsung Tab S2). I have tried most of the ideas mentioned above, apart from playing with IGMP as my router did not offer that facility.

I don’t expect this “solution” (fingers crossed) to help people other than to say this bug is a weird one and I’m glad it’s not me trying to solve it.

More weirdness !

After my post last night when I followed @dhusky suggestion, I came home tonight and was faced with the same ‘searching for core’ :tired_face:

Tried toggling IGMP proxy on the router but to no avail (does not require a reboot)

Rebooted core with IGMP proxy on, and voila, android connects again

I suspect one reason the devs cannot squash this bug (as they can’t reproduce it) is because we all have different routers which handle IGMP snooping tables in different ways. May I suggest devs try to reproduce this using a router that one of us sufferers use?

I have a Netgear Orbi FWIW, but I’m sure there are cheaper models people are using

Just a thought … :face_with_monocle:

Rebooting the router often temporarily allows the Core to connect. I suspect it will drop again soon if the IGMP fix didn’t work for you.

Yes, that was my experience from summer 2017 until early 2018. Then, for reasons I never understood, the problem went away. But by then, all systems software in my firmware on my network had changed, so my guess is that whatever subtle interaction was causing the problem went away. My overall suspicion is that there is an obscure race condition in the Mono<->Linux kernel network code (Android is based on a Linux kernel) that is tickled by some networking condition.

1 Like

Roon has started working for me just this morning with my Android Pixel 2 phone. I haven’t tried it in a long time so I don’t know what the difference is that made it work. Before it would consistently fail every time. Could be upgraded roon core, roon app, or maybe the recent upgrade of my Pixel to Android 9 Pie.

I will continue to update this thread if I have problems again.

Anyone else get their phone working after the Android upgrade?

Both my Android devices connected right away. Keeping my fingers crossed

Gone again

Yeah, its very hit or miss. It will work one day and then not the next. It only happens with my Android devices (though I don’t own any iOS devices, so can’t say if it happens there as well). My Windows and Mac machines never fail to find my core.

I’ve found that when I lose the Core, usually the first time I try and use the android app of an evening, if I reboot the server whilst the app is searching it reconnects and then is fine … for a bit !

The problem still appears im my setup from time to time (one time every 3 months). Rebooting the core (which is running on Ubuntu) AND stopping/starting the “roonserver” service fixes the problem right away. If it stays that way I would dare to say, that I can live with it…

I’m just starting with Roon and facing the same problem with following devices:

  • Lenovo P2 (P2a42) phone running Android 7.0
  • Lenovo Yoga Tab3 Pro (YT3-X90F) tablet running Android 6.0.1

Interestingly both show up in Roon (on my PC) under Settings > Audio as long as the Roon app is running on them (showing the searching for Roon core message). If I activate and configure them on the PC, I can even play music on them. Looks as the Bridge part of Roon is working and only the Control part won’t / can’t launch. So as the Bridge part is working, it shouldn’t be a network issue or am I wrong?

So my only working Control device besides my PC (which is on the lower floor) is my Samsung Galaxy Tab S2 (SM-T810) running Android 7.0, which is actually intended for other purposes.