Android app - Roon's Achilles heel?

I can confirm that the Meridian Explorer2 also works fine with an USB OTG cable on my Galaxy Note 8.

It depends on the device, some low end Samsung phones don’t support OTG hence won’t work with the Red, my J1 doesn’t for example

You need to check for OTG compatibility


1 Like

I think we need to make a distinction here. The Android app on a tablet works pretty well for me, even on afire hd8. From what I’ve heard it is identical in operation to the iPad. The optimisation for the phone is a different thing, the screen is really too small to give you the Roon experience and it feels like an afterthought. I would like to have the ability to use the otg digital out and the fact that better Android phones can use ldac and aptx codes would be really nice to have that ability.

Yeah, I have the same experience. Leave it on all the time, works fine. Can even use the HD 8 as an endpoint, plugging in headphones. I do sometimes see the effect where its display of what’s playing is falling farther and farther behind what’s actually playing, though. And I did fix the DPI of the tablet to reflect its actual DPI, so it’s landscape mode.

I’ve just changed phone from a Moto G3 (5" screen) to an LG V30 (6"). Early days but where I didn’t use the Moto as a control I am doing with the V30. And it’s nice. Of course it’s not as good as a tablet but there is only so much you can do with reduced real estate. IMO they’ve done a good job though.


1 Like

Until last week I had been using the Roon android app on a pixel. I had no major issues except that every day I needed to restart roon server in order for the android app to connect. Once connected though I was good to go the rest of the day with no issues. Needless to say this was still a pain. I tried a lot of ways to solve it in my network and in Windows…even resorting to using windows task scheduler to restart roon server everyday. Well, I switched to an iPhone last week and that issue has disappeared. All this time I figured it was something to do with my network…glad to know it wasn’t.

@Matt actually I’ve had that issue as well! Hadn’t really bothered to troubleshoot it and wasn’t necessarily blaming roon. Like you I’ve been assuming it’s a network thing. Don’t really want to buy an apple device just to use roon as it’s a fairly costly endeavor as it is. Maybe I should forget the lifetime exists and just think of Roon in terms of $10 bucks a month (i.e. $120/year). I guess I can just use my windows
laptop as the remote. Kinda clunky but full functionality & at least it does fold back into a tablet, albeit a large and unwieldy one. Roon is amazing in a lot of ways, but not quite the perfect solution I was hoping for. I’m still on the fence about continuing after the trial.

I’ve put an AIO as the master controller on top of my audio rack and use the Web Controller extension instead of Roon, that doesn’t work on my Lenovo devices, for playback control.

The original post in this thread was only about Roon as a remote on Android. That’s how I use it, and it’s worked very well for me, using Pixel 2, LG V35, and Amazon Fire HD10 tablet (the HD10 has some issues, but not Roon’s fault - see my separate thread on that).

I also have an iPad, so I’ve seen both, and while the iPad is marginally more realiable at connecting and not having to reconnect, it’s not a significant difference for me.

I particularly recommend the HD10 as a remote, since it’s often discounted under $100 and is a solid alternative to iPad. (See HD10 thread on configuration tips.)

1 Like

android app needs a notification play/pause button asap


I reported issues with Android version 2 years ago, but the Roon R&D team don’t respond with any plans for a new version. On my V10, there is a staggering sound whenever I turn to another app, e.g. using the browser. This is because this app uses the Services module of Android. This is disqualifying so I have since long reverted to Tidal for Android.

However, the use of V10 as an endpoint, using the built in ESS 9018 DAC, works fine. This provides a decent audio quality compared to more standard DACs. It means one can use an android phone (V10 in my case) as a “wireless DAC”. Used in this context, only using it for Roon, the app works fine.

I have 3 LG V10 connected here and there in the house, to various hifi gear.

I salute any effort made by the Roon team to get rid of this very old bug. It is a problem on some phones, not a problem on others, but it should be a problem on NO phones. The use of services is in dire need of revision.


I’ve just canceled my Roon trial. I’m just going to use a Plex-based solution. I already purchased the lifetime premium membership for Plex. I converted my Pi B 3+ w/ hifiberry pro + from Volumio to a Rasplex headless player, and control it with the plex app. Was a pain to get set up (as it turns out there’s no official release of Rasplex that’s compatible with the Pi 3 B+) but now works great. Plex provides some metadata. Not like Roon, but with these nagging Android issues, which no Roon dev has so much as commented on, I just can’t justify the considerable expense. The Rasplex is not as good as what Roon could be, but it’s much better than the functional but very bare bones volumio setup I had before, and totally free of charge.

It’s a lot to pay, for what is essentially Volumio with Allmusic baked in (both completely free of charge to access and use, individually), and a problematic Android app. It’s not as if Android is a fringe platform. And people have been complaining for literally years. If the Android app was ever free of the issues plaguing it that have been discussed, along with adding the Focus feature and editing to the Android app, I’d reconsider. But there hasn’t been much indication that this will ever happen.

Good luck everyone. I’m out. Peace.


Strange. I used an Samsung Tab S2 and now an Huawei mediapad 5 10" tablet - non of the above problems noticed, and I am a user since the start of Roon. Same for my telephone, first Samsung S6, now Xiaomi Mi Mix2, none of those problems either. Apart from the wish to rotate screens when turning the device i am fairly happy

1 Like

You are not alone -

Android app having trouble finding Linux Core

Workarounds include 1) turning off IGMP snooping on your router, if it will let you, and 2) going into ROCK settings, if you use ROCK, and hitting “Save”.

One plus 5 and galaxy tab S2 here and I don’t have issues. Yes it has to reconnect when it goes into background but it always reconnects quickly and I don’t have an issue with that. If I turn of the battery management it drains the battery in no time so this to me is preferable. I agree it still needs work but it’s better than some I have used.

Biggest issue with the Android app is that audio stutters when using the phone as playback device and the app is backgrounded. Couldn’t find my iPhone headphone adapter so tried mowing the lawn whilst listening to tunes via my Pixel 2… needless to say it didn’t work very well as I couldn’t minimise the app and it kept on stopping playback as the phone moved in my pocket

1 Like

The MOST annoying aspect is the inability of the Android app to access the internal dac. On my FiiO M11, the Qobuz app has no trouble doing this. The Room app still goes through the crippled core Audio of Android. Grrrrr!
When will Room do what Qobuz seemingly has no problem doing?

1 Like

See this recent post by Brian.

What I would like is an ‘Android light’ app: just a simple remote (search, play, stop, forward, rewind, album cover) for Roon. For the full Roon experience I have my laptop, when I’m cooking or something I just need a light version on my phone.

1 Like

I have said in the past that when it comes to mobile devices that different uses require different interfaces. The interface I want when running on a treadmill is not the full interface I might want at home as a full on controller. Same with being in an Auto, etc etc etc.