Apple HomePod Stereo Pair Support

That is not accurate at all.

Hi Dylan,

any news on this topic? Since HomePods became affordable as a smart speaker in every room with the HomePod mini the demand for this feature should be a lot stronger than it has been when this thread was started.
In rooms with one HomePod Roon works perfectly fine as a source. But there is the occasional room with HomePod or HomePod mini as a stereo pair.
In order to make that work via DSP functions one would have to unpair the speakers in iOS. So I can only make them work as a stereo pair in either Roon OR iOS.
I love Roon, but still: the software is not exactly cheap. IMHO, I dont think it would be a wise choice of Roonlabs to ignore Airplay2 on the longrun.
I know, you have aready responded to this in 2018 but again: HomePods have become a lot more popular and present in our homes since the HomePod mini.

I think I am not alone with this request. Any new developments here? Looking forward to your reply.

Hi @itzlbritzl
I too have a pair of HomePod Minis that I have configured in iOS as a stereo pair, but also, using instructions elsewhere on these forums configured, as best as possible, as a ‘stereo’ pair in Roon (you add one speaker as a zone & use DSP in zone to mute one channel, then add other speaker as another one, use DSP to mute other channel, then group those zones). It’s not a perfect stereo image, but it works well for me as just a zone for background music / non critical listening.

Why so aggravated? If an explanation like yours had been given previously in this debate/thread things would have been a lot clearer.
I am just a user, I got other things to do than delving into development history for hours before you bestow me with the honor of being allowed to ask a question.

Nobody is “framing” anything here. It is basic commination: If your reply would have been given in the first place, things would have been pretty clear, wouldnt they?

Would have been better to answer with details (like you did), maybe minus the misplaced aggresion, wouldnt it?

All I read from Roon here was “we dont have any plans considering this” leading to the false assumption that it might be Roon’s choice to “ignore” Airplay2. Again: communication 101.

I agree totally… I thought of this workaround, too. Any of course, nobody uses HomePods mini for critical listening. Somehow it failed for me.
I was under the impression that things either worked in iOS or Roon as a stereo pair. I might have to look into this one more time.

Apple themselves are just getting around to adding AirPlay 2 to macOS Big Sur, allowing for playback to a stereo pair of HomePods on system level. AFAIK, licensing AirPlay 2 is for hardware only.

I use a few old iPhones I had laying around as bridges to my HomePods: run Roon, activate local endpoint, set playback destination to HomePods. (I automated this with a few Shortcuts and mapped these to the buttons of a presentation remote, so I can turn the iPhone from Apple Music endpoint to Roon endpoint and vice versa with the click of a button).

The signal path does not look half bad (playing Roon > iPhone > stereo HomePods):

The old iPhones stand on little docks, so they also function as little Now playing screens. Selecting the HomePod playback zone on other iDevices enables Now playing (lock screen) controls for Roon. Volume control is done with bluetooth remotes. I wrote a little bit about it here:

3 Likes

Ok so I’m sitting listening to Bill Evans Top do of the gate on two HomePod Mini on my deck. Much to my surprise I’m not listening to dual mono but stereo. My theory, the Big Sur update adding Airplay 2 stereo home pod support is some translating to Roon. And for the naysayers, I listen to a lot of 60’s Jazz where instrument placement is precise is recordings. I’m hearing stereo. In Big Sur this HomePod pair is paired for stereo.

Thinking it through it makes sense. The transport to the HomePods is Airplay. So from the Roon Core, Mac Mini Big Sur, it’s sending a stereo stream with Airplay. Now Roon has the Minis grouped but Airplay is in control. Anyone else try this and hearing this.

It seems when i stream to my 2 HomePods mini grouped using Roon they are playing in stereo , there’s different sounds coming from each HomePod and no echo effect.

I made a group on iOs Home app first then a group using Roon.

Is it due to last update ? or the fact that it’s HomePods Minis ? An update from Apple ?

Apple fixed it in a relatively recent release after originally breaking it. Roon was never involved in this issue.
Hopefully you are happy with the outcome

Oh ok i thought it was necessary for Roon to handle Airplay 2 to be able to do this …

I think a lot of people thought that, but Apple fixed what they broke and everything worked again. All users happy after months of complaints

:slight_smile:

ok so nearly no more problem with HomePods …

For my part I still constantly have one of the 4 HomePods Mini not working through Roon and the strange part of it is that’s not everytime the same one that fails, it changes … can’t figure why for the moment but it’s a bit frustrating. I posted here but no clue for the moment …

Sorry KelFab they are not something I have any of.
I am guessing you are linking them on the Apple side and then playing from Roon.

I alway think it’s worth getting back to basics for debugging these issues, though you can not always fix them as they can get a bit complicated with wireless protocols

They are not all linked together, only 2 of the 4 are linked. Even it they are not linked at all (I also tried with none of them linked together) for some reason not clear, one of the 4 does not play when I launch music on it. The timer on Roon for this audio zone stays at 0:00 or the previous value where it was paused.

So I have seen that on one of my Sonos devices playing over Airplay.
Currently it is turned off, but I will be going in my garden again soon so I will have to fix it or not have music.
Have you tried renaming it or removing it from Roon, which is what I was looking to do?

When I posted 30 minutes ago, that was the one on my living room that was not playing, now 30 minutes later it’s the one on my room, and the one in the living room is fine …

OK that sounds a little strange, and they might suggest networking
You probably want to open a ticket in the support thread (if you have not yet) and get one of the support team to look at your logs on Tuesday/Wednesday.
At least the logs should help you figure out what is happening

That’s what I did : Here
But for the moment no answer, I’ll wait till next week then up the thread if no answer.

They don’t generally work weekends and bank holidays, so it is likely to be Tuesday now.
Good luck though

1 Like