Arc APK still showing version 81 not 84[Solved]

Attempted to download the latest Arc apk since this never comes through Google play. After install, version is still showing as version 81 and not 84.

Same here, downloaded 84 and software version still 81

But USB Driver section is here, not working with TempoTec Sonata HD V, volume uncontrollable, max or mute only.

Seems like links were forgotten maybe? @vova

I just found that I already have 1160 and ARC 84 offered through the Play Store beta

1 Like

Thanks, 84 did come through Google play after I uninstalled first. Have not been able to update EA Arc through Google Play in quite a while.

I seemed to have issues (not sure if they were real or just slow) for quite a while, before EA went public, with getting Beta through the appstore, so after some waiting I always installed from APK. When the next updated came around, I waited again, nothing happened, so APK again. Found that a bit annoying but hey ho.

Now after EA went public, and Roonlabs wrote that they are sorting out the appstore beta for more users, I uninstalled the APKs, reinstalled from the appstore beta, and have received the previous and this update in a timely manner. Not sure if my actions were all voodoo, but now it seems to work.

1 Like

Did same in same situation with same result. One caveat - uninstalling the APK originated build 81 before installing build 84 via app store (it refused to install over the top), meant losing my downloads. Expected and doesn’t bother me, but may bother some.


I re-downloaded the build to the server and verified, should be 84 now.