ARC B231 Suddenly can’t connect to ROCK B1363 after updating

It always worked, but after the update I get this in ARC (while Roon Remote and ROCK work normally)

After this screen came up the first time it found the ROCK quickly and showed the Connect button. After clicking it, it started alternating with this, in a repeating cycle between the two screens,

on home wifi, but it never logs in and tapping the check mark etc doesn’t help. Rebooted ROCK too.

iOS 17.3, iPhone 15 Pro Max

I have ARC installed on an iPad as well, where it fails, too, but differently:

On the iPad I had to first log in, too.

ROCK is fine:

After it cycles for a long while through the two screens, it stops with this screen where it says that it saw the server last just recently, but nevertheless no connect

Turning off wifi and trying with 5G doesn’t help either

No problems here with iPhone 13 Pro Max connecting to my Roon Nucleus. I haven’t updated my iPads. CarPlay also working well.

Thanks, weird. I changed nothing except the Roon updates

1 Like

Have you managed to get it to connect?

I’ve just updated and did not have any issues, although I did it with gritted teeth :grin:

MOCK Server


2009 MacPro running Ventura.
iPad Pro 12.9 Gen 2, iPadOS 17.3
iPhone 12 Pro, iOS 17.3

Nope, it stayed the same as described. I’d reinstall and with SDL it’s less of a pain, but I doubt it would help as it’s not working on the iPad either. We’ll see what RoonLabs has to say :man_shrugging:

Same issue I can’t connect either.
Edit: Clearing the app data fixed it.

1 Like

I really hope they release a build that fixes it because I don’t want to spend several days off and on resyncing my entire collection again (assuming they still haven’t fixed background syncing lol)

I’d be more upset if this happened in prod but this is early access, you kind of have to expect things like this.


I just updated my iPad Gen 8 and Roon ARC would not connect. So, I deleted the app and downloaded from scratch using TestFlight. This time it had me log into my Roon account, then Roon ARC did a sync with my Nucleus and all is good.

EDIT: Same thing with iPad Mini 6.

Thanks for the tip…- deleted the app & it’s data, then re-installed. Working again.

It is concerning - these updates - that when installed lead to such an issue.

Roon, will you please add a note to the test-flight update, mentioning that the update may break the connection, and there could be a need to delete - and re-install.

It is of an annoyance - disturbance when you get into the car to drive - and press play on ARC and it doesn’t work. Leads me thinking to - is there an issue of the connection between the phone and the car, or with the mobile service provider, or with the iphone that apple wants me to do another upgrade. Anything can go wrong…I understand that we’re beta testers - so, issues are expected - but a warrning note before the update - or with the update would be most appreciated.

It doesn’t need a note. It’s beta software. If you don’t want problems like this, don’t use beta software.


Valid point! Sadly though I did bump into this exact same problem with the proper release. Its an issue that may happen with both the beta and the normal release.

Guess its something to live with as opposed to comment in the community about.


Hi @Suedkiez ! Thank you for the report. Apologies for the unpleasant experience. Please try logging back into ARC, press the back button on the server selection screen, and follow the login flow.
Kind regards,

It took six attempts through the back button and login cycle before it got past the tick screen as reported by @Suedkiez

But it’s wiped 60gb of downloads, so not ideal…

I had the same problem. After clicking back and going through the authentication screen all downloads are lost (again). But storage is still used.

70 minutes of music enough for 9 days of listening? That would be a very painful days…

Same problem with the server on Windows and ARC on Android.
Logging in again, it worked.
He kept the settings, the queue and the song it was playing before the update but I’m not sure about the downloads.
They are currently empty, but I had reinstalled ARC with the previous build for the duplication and recent activity issue, so I don’t know if SDL had downloaded something after this.

Thanks. After a several tries, that did it. Strangely, I did try this before, but I didn’t manage to go back. I saw the < arrow and thought “ok this should probably get me back” but it didn’t.

Now I realize that I probably didn’t hit the very small tap target, and I didn’t try repeatedly because I didn’t know for sure that it should work. Now that you told me, I kept trying until it did :slight_smile:

Like for @ged_hickman1, It wiped my 30 GB SDL and a bunch of manual downloads, too. :frowning:
It doesn’t show storage as used, though. And the SDK settings (which had been enabled, 30 GB, CD quality) were reset to defaults (off, 5 GB, balanced)

@oleh So I was SDL re-downloading after the above post, not using the phone. When I picked it up to do something else, I was greeted by an ARC crash message - reported through the iPhone.

Then I started ARC and was greeted by the connect screen, saying “who is listening today?” where the profile icons should be, but there weren’t any, so I couldn’t log in with the profile. I force quit and restarted ARC and this time it logged me in right away, but the SDL downloads (and one manual download) from the previous download session were wiped AGAIN! This time, though, the SDL settings were as I had left them previously (enabled, 30 GB, CD quality)

Edit: A minute later, I notice that Roon reports 11.2 GB storage used although SDL has downloaded just 16 albums in CD quality, which amounts to about 5 GB.

Edit 2: And as I am writing the above, with ARC in the foreground and me just having finished scrolling through the download list, ARC crashed AGAIN. This is getting tedious now, beta software or not. Tried to report the crash through the iPhone but the crash message disappeared because I switched to another app :frowning:

Edit 3: This time the downloads were not wiped after restarting ARC. By now it has downloaded 23 albums, i.e. about 8 GB, and the Roon storage report is still the same 11.2 GB, so this is becoming more realistic and I suppose the 11.2 never were the real storage but just a visual artifact

Edit 4: Now that SDL has made it to 33 albums, the reported storage has started to climb above 11.2 GB, so this is now OK

Edit 5: Eventually it filled up the whole 30 GB designated SDL storage and since then it has been fine in general:
However, the Recent Activity - Played is displayed but missing a bunch of plays since yesterday. Recent Activity - Added is also displayed and up to date (but I haven’t added in a few days)

Another user who had to wipe out hundreds of downloads (by wiping cache and Storage) before ARC would connect again.

Currently set back up and allowing ARC to download another 30GB of music automatically.