ARC bit-perfect in android phone!

Yes, everytime i reconnect the M15 to the usb port and start playing a track, the volume blows my iems.
Pressing volume down does do nothing. Pressing volume up reduces the volume immediately to a resonable level.
At all times before reconnecting, i lowered the volume to minimum.

I refrain from reties, because i have expensive (as well as sensitive) iems (fir audio xe6).

For the time being increase or decrease volume control then start playing music. Have to do everything if u close the app and open or unplug and plug back USB DAC. Hope a fix for my AK-HC2. We are getting there😊

Thank you, @Moshe_Zolotov. Could you, please, reproduce this issue once again and let me know the timestamp when it happened? I am going to request a diagnostics report from your device.

@MusicFidelity, we were able to reproduce the issue with your DAC and created a ticket for our dev team. I hope they will be able figure how to fix it soon.



1 Like

Well guys, i am confused. Tried it now again right now, and the max volume issue is gone. I did not update anything (still on build 111). Music starts at a resonable (slightly high) level and can be fully controlled via the S22 volume keys. When disconnecting the usb connection and plugging it back it resumes at the volume level last used (even when set to minimum).
I really cannot understand how was it fixed, because last time it exploded my ears when initiating and after each reconnection of the usb dac.

Edit: played with it more. Noticed the following: after initiating the ARC app, volume starts at a slightly higher level (not max as before) it is not overwhelming. I can reduce it by pressing the up volume (?) on the S22.
After reconnecting the usb dac (following its disconnection) while the app is running, volume level is mostly maintained (once or twice it resumed with higher level).

Please take the timestsmp of this message.

1 Like

Yes in build 111, in the case of Ak-HC2, it doesn’t play at max volume but high enough. It is still high enough to feel discomfort. So have to be careful to move the volume up or down before playing the music.

Same success* on Samsung S22 w/ ARC but w/ OPPO HA2 Dac/Amp.
–Going to test (same source) but w/ Meridian Explorer I & II Dac/Amp & Topping D50 DAC.

*Tested Samsung A6 Lite tablet w/ OPPO HA2 successfully.
–Going to test A6Lite w/ Meridian Explorer I & II & a Topping D50 DAC this evening.

**Success = ARC App now shows & plays bit perfect :notes:, where before engaging Beta mode, it would not on the above combos.

Same here with Zorloo Ztella. The build 111 eases the issue by far but not really fixed it.

Btw since The USB DAC driver introduction I’ve noticed another issue with my Sony Xperia II. If I have connected the USB DAC and utilizing it in ARC then the first time I receive a call I have no audio through the smartphone speaker. I have to end the call and retry. Will do some investigation if it’s really related to ARC or just Sony :slight_smile:

I have same issue when on a Zoom and I get a call, same thing happens. I think it’s an android issue. Been doing it alot lately (last 4 / 5 months)

I’m loving ARC, but has anyone seen “disconnects” on certain DACs, my iFi micro iDSD Black Label randomly (but usually in the first 5 minutes) resets, basically it’s unusable, the “Open Roon ARC to handle iFi” prompt starts popping up randomly and pressing “OK” usually either repeats the prompt or it seems to work but when you resume the track you get a hardware error…

Pixel 6A on Android 13

A new observation.
ARC beta build 111.
Timestamp: At around 16:30 my local time (gmt +3).
I entered my car while listening to ARC, usb driver set, at a reasonable volume (s22 ultra media volume). My phone autimatically paird with my car’s bluetooth audio and then, the the phone’s media volume shifted to BT volume at max swing, the music over my usb dac (questyle m15) became unbearable. Adjudting the BT volume did not help. I had to disconnect the usb connection and plug it back, that, restored the volume level (no more BT volume). I did not try it again, for fear for my costly iems.

1 Like

It was indeed working for me until I updated Qudelix to 2.0 firmware. Now it’s the same issue as before build 1182. Are you facing the same problem?

Yep, same for me.
Updated the Qudelix to FW v2.0 and now get an audio driver error in Arc.

1 Like

Quick question, I wouldn’t mind a portable (battery) speaker (with decent size woofers) that is supported by ARC, any suggestions?

Good sound quality of course and a decent USB DAC built in, is this sort of thing even available?

Just started using ARC after calling my ISP and getting CGNAT disabled.

I’m using a Hidizs S9 Pro DAC/AMP on a Samsung Note 20 Ultra and the volume steps are not working correctly. Even after installing Sound Assistant which allows you to manually set the volume steps on Samsung devices, it seems that most presses of the volume rocker yield no result only for a significant jump after several presses. I have no such issues while using UAPP after enabling hardware volume control from within the app.

This issue currently makes granular volume control impossible for me.

QNAP, what is that?

Sorry I can’t help with ARC volume control on your DAC.

Oops, meant CGNAT…edited in post.

1 Like

Perhaps check the DAC vendors website for a mobile volume app like mine has?

1 Like

Thanks for the suggestion, but it doesn’t look as though Hidizs offer anything like that.


I said ARC had problems in combo with the Douk Audio U2 (USB to spdif converter). I found that ARC is not at fault!! The combo did not work on my Xiaomi Pocophone F1 but did work flawlessly on another Xiaomi Redmi 9C. Investigating the issue it seems Pocophone F1 is erratic in it’s usb audio department in general, and this is not to be solved.


This is to report one success and one failure with ARC + USB driver on Android. Both are with latest ARC (1.0 111) as of this date.

Success: Samsung A53 5G phone running Android 12.

Failure: Lenovo Tab P11 (tablet) running Android 11. The particular device attached (Matrix mini-i Pro 3) is not identified (identified as “null”) and an attempt to play leads to an error message from Roon ARC.

I’m grateful to have it working well on the phone. It would be lovely to have it working with the tablet, too, with its larger screen.

P.S. The exact model number of the tablet is Lenovo TB-J606F.