ARC can’t access roon core

Roon Core Machine

Nucleus ethernet to router

Networking Gear & Setup Details

Orbi RBR 850 router

Connected Audio Devices

Peachtree Nova 300 amp, Mac Mini M1, Chord Poly, iPhone XR, Chord Muso.

Number of Tracks in Library

80,000

Description of Issue

ARC app can’t connect to roon core. Orbi router has uPnP enabled.
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_natpmp”:true},
“upnp_autoconfig”: {“status”:“NotFound”}
}
Cheers James

You may need to manually configure your router port forwarding.

Thanks Jim, I hope that’s not the case as I’m pretty unfamiliar with that procedure.

Error message has changed.Arc seems to be working on my home local network. Not working away from home.

That’s why you need to do the port forwarding.

Had same error: Allow Port forwarding or allow “automatic port setting for device” in router, saved it for me!

Thanks. I’m not tech savvy when it comes to network settings etc. How do you perform the port forwarding procedure. I have an orbi mesh router RBR 850 connected to our service providers(Telstra) smart Modem/Router.It works well throughout the whole house. I don’t want to disrupt anything as my wife’s business uses our network.
cheers
James

Sound like you need to call in an IT-technician…

Same issue for me. UPNP is working just fine on my router, my Plex server uses it.

Here’s the error I get, which I think may be the same as the above;

{
“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“103.115.191.41”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

I’m hoping Roon support can help.

Can someone help me here. I’ve tried to set up port forwarding on my orbi router. I used the IP for the roon core as the internal ip address and selected the port 55000. Also TCP ticked.
This still doesn’t work.
Now I’m thinking I may need to change the port forwarding on the modem/router the orbi is connected to. This sort of makes sense as the service providers modem/ router is upstream to the orbi.
I don’t know why this is so complicated. I have a fairly average setup here.

HI Peter,
did you get ARC sorted? No luck with me.
cheers
James

I didn’t succeed in getting UPNP to work, so I set it up manually. In my routers configuration I used MAC address reservation to give my Roon Server a fixed IP address & set up port forwarding to it’s IP address using the port number that my Roon server wanted to use. It’s just a little bit more work than using UPNP, (if it works).

I haven’t tested it outside my house yet, I will later today.

I have the same router and I’m not getting a connection.

I have enabled upnp and done manual port forwarding.

Still getting an error message.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“195.252.198.182”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

I’ve organized port forwarding and uPnP on my router as best as I can understand from roon’s info ,( never having any experience with this side of things). Still no result.:slightly_frowning_face: I’m hoping support will chime in soon.

Thanks Peter

Can someone clarify to me whether support will respond to me? I realise they are busy . I’m just not sure if I have to tag them into this thread.
Cheers

Here is my latest fail report after trying various setting changes,(port forwarding, upnp checking, LAN address reservation for Nucleus). Still waiting for support assistance.
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“101.191.31.195”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}