ARC can't connect to Core (modem Huawei HG8145V5)

Roon Core Machine

iMac 2022 model running Ventura iOs

Networking Gear & Setup Details

modem Huawei HG8145V5 connected to a deco mesh from tp link but the Core is connected directly to the modem by Wifi and Ethernet cable ( right now cable is disable)

  1. Who is your internet service provider?

Total Play ( I’m in Mexico)

  1. Please list the make and model of your modem and router?
    modem Huawei HG8145V5

  2. Do you have any additional network hardware, like additional routers or managed switches?
    tp link deco mesh

  3. Does your network have any VPNs, proxy servers, or enterprise-grade security?


Connected Audio Devices

USB : HOLO spring 3

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

this is the diagnostic from Roon. I already tried to add manually the port forward adding a new “IPv4 Port Mapping” and a new “Port Trigger Configuration” inside de modem advanced configuration. Also enable the UPnp multiple times by now.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“187.ddd.eee.ccc”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

Thanks in advance for your time

Welcome to the Roon community forum, @Sebastian_Arana-Garz.

The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

So, as I understand this issue is related to the Deco Mesh running along with the modem right?

You have two networks: 172.x.x.0 and You need to setup port forwarding in the Huawei and TP-Link, i.e., the Huawei should forward port 55000* to the TP-Link, and the TP-Link should forward 55000 to the iMac (core).

Note that Ethernet and Wi-Fi will use a different IP address, and Ethernet is preferable.

*Use 55000 or the port shown in Roon > Setting > Roon ARC.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.