ARC connecting problem

Roon Server Machine

Roon Nucleus B

Networking Gear & Setup Details

Tp-link archer c64, nucleus coonected via cable. No VPN. Dynamic IP

Connected Audio Devices

HEGEL H390 via WIFI

Number of Tracks in Library

NO LIBRARY

Description of Issue

After the initial connection ARC was working from the box, but after a week my provider was hucked and there were also some electricity shotdowns (I am from Ukraine) the connection was failed. Now it is workin within my home web but no connection outside. Here is the test info

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“188.ddd.eee.fff”,“actual_external_ipv6”:“null”,“router_external_ip”:“100.aaa.bbb.ccc”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true}
}

The diagnostic message shows that you have a redundant layer of networking in your setup. That is, there are two networks for ARC to traverse: 100.aaa.bbb.ccc and 188.ddd.eee.fff. Typically, this occurs when you have two routers in your home network.

If you definitely don’t have more than one router, e.g. ISP modem, plus the TP-Link, then it may be that the ISP has done something to restore the service. Please identify all networking devices used in your home.

1 Like

Mercurysys ME10 - 2 pcs (TV and Hegel); TAB S6 light - 1 pc; Galaxy s22 phone - 1 pc; wifi electric socket - 1 pc; phone#2 - 1pc (dont remember the brand:))

What I meant was devices such as your TP-Link Archer, and Wi-Fi hubs or extenders, and other equipment supplied by your ISP.

No devices by my provider. Only Archer and Mercsys wifi extenders

Thanks for this. Can you confirm if your Nucleus is connected directly into the Archer, or if it’s plugged into the Mercsys?

Directly. Mercurysys are used for Hegel amplifier and TV connection

In that case, it’s likely that the issue is caused by changes upstream with your ISP.

Nonetheless, it would be helpful if you confirmed the IP address of your Nucleus, and the IP address of the WAN link reported by the Archer.

Where can I find this WAN link IP?

The router that is connected to the internet will have some kind of status page on its web admin interface where it shows its external (internet) IP address

1 Like

Please confirm what is connected to the blue port on the Archer; is there another device or did your ISP install an Ethernet socket?

The status page is usually the first menu item on the left. For example: System Status.

image

1 Like

What I see is:
Nucleus 192.168.0.101
Internet IP on Archer page [moderated: public IP address obfuscated 100.80.xxx.yyy]

Here is also

IPv4 LAN IP 192.168.0.1

192.x addresses are not it, because they are private on the local network and not routed on the internet.

I suppose the other one that you posted, which was moderated to 100.80.xxx.yyy, is the one

Blueport is connected directly to the provider cable.

Maybe it will help. The provider have sent me the message that after the hucking attack some equipment was broken and they changing it. Could it happen that before the cable which is coming to my router now there is some other equipment that produces another external IP?

The public addresses were posted as is. We have the following networks.

  • 188.n.n.0 Public
  • 100.n.n.0 Private? If it’s 100.64.0.0, this would indicate CGNAT.
  • 192.168.0.0 Private

What’s at the other end of the cable?

1 Like

The cable goes to the provider’s “box” outside my flat. What is inside I dont know. Its closed

If you could confirm the WAN IP on the Archer, this would help to confirm if carrier-grade NAT (GGNAT) is used. If this is the situation, Roon will not work unless you ask your ISP for a fixed IP address to enable port forwarding.

1 Like

I think tht the IP you asking is 100.80.xxx.yyy but accordin to the TP-LINK.COM it is not a true external IP, this IP is given by provider. Am I understood you right that in this case the only solution is to request provider for static IP?