ARC Connection Problem

Roon Core Machine

MacBook Pro (Retina Mid 2012)
2.3 GHz Quad Core i7
8 GB RAM

Networking Gear & Setup Details

Netgear Orbi RBR50
Ethernet Connection

Connected Audio Devices

2 Apple TVs running Airplay via WiFi
1 Raspberry Pi running RAAT via WiFi
1 Nativ Vita running RAAT via Ethernet

Number of Tracks in Library

16,000 Tracks

Description of Issue

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“71.173.146.226”,“router_external_ip”:null},
“natpmp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_upnp”:true}
}

What country and ISP?

USA; Verizon FIOS

Have you tried something on this list: Routers and ISPs

Ultimately, configuring manual port forwarding solved my issues. UPnP didn’t seem to allow me to stay connected and I had to keep fiddling with switching it on and off on the Verizon router. Been rock solid since I configured the port manually. Let us know how you do!

1 Like

I’ve configured port forwarding on the Orbi, but from the comments it looks like I have to turn off UPnP on the Verizon router, too. I’ll see if doing that works.

If you have two routers both need port forwarding as you’ve got a double nat situation. Port forward from isp router to your router and port forward your router to Roon.

1 Like

Yes. Enabled port forwarding on both. WAS able to connect to ARC when I bypassed the Orbi and connected directly through the Verizon router. It seems from the comments that I might have to configure IP Passthrough/Bridge Mode on the Verizon router?

Quite a few Orbi owners are having issues.

I have my Orbi in AP mode and wifi on the Verizon router off. The Verizon router does all the routing/DNS business and the Orbi just deals with the wifi. No double NAT this way. I have UPnP on, but to enable another service. ARC is completely stable via manual port forwarding configured on the Verizon router. I did also switch my core to a static IP address.

I’m up and running with Fios and Orbi and ARC is working like a charm for me, so it can be done. Unfortunately, I’m not a networking expert, so I can tell you what’s worked for me, but I can’t tell you why!