ARC Connection Problem

Roon Core Machine

MacBook Pro (Retina Mid 2012)
2.3 GHz Quad Core i7

Networking Gear & Setup Details

Netgear Orbi RBR50
Ethernet Connection

Connected Audio Devices

2 Apple TVs running Airplay via WiFi
1 Raspberry Pi running RAAT via WiFi
1 Nativ Vita running RAAT via Ethernet

Number of Tracks in Library

16,000 Tracks

Description of Issue

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

What country and ISP?

USA; Verizon FIOS

Have you tried something on this list: Routers and ISPs

Ultimately, configuring manual port forwarding solved my issues. UPnP didn’t seem to allow me to stay connected and I had to keep fiddling with switching it on and off on the Verizon router. Been rock solid since I configured the port manually. Let us know how you do!

1 Like

I’ve configured port forwarding on the Orbi, but from the comments it looks like I have to turn off UPnP on the Verizon router, too. I’ll see if doing that works.

If you have two routers both need port forwarding as you’ve got a double nat situation. Port forward from isp router to your router and port forward your router to Roon.

1 Like

Yes. Enabled port forwarding on both. WAS able to connect to ARC when I bypassed the Orbi and connected directly through the Verizon router. It seems from the comments that I might have to configure IP Passthrough/Bridge Mode on the Verizon router?

Quite a few Orbi owners are having issues.

I have my Orbi in AP mode and wifi on the Verizon router off. The Verizon router does all the routing/DNS business and the Orbi just deals with the wifi. No double NAT this way. I have UPnP on, but to enable another service. ARC is completely stable via manual port forwarding configured on the Verizon router. I did also switch my core to a static IP address.

I’m up and running with Fios and Orbi and ARC is working like a charm for me, so it can be done. Unfortunately, I’m not a networking expert, so I can tell you what’s worked for me, but I can’t tell you why!

Hey @Michael_Jarman,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. I wanted to check in to see if you’ve been able to get Arc up and running? The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I got it to work. Putting the modem in bridge mode and running a double NAT would disable WiFi on the modem (a Netgear Orbi). My preference was not to do that. I WAS able to run my Macbook Pro that hosts the Roon Core both wired and wireless (Ethernet connection PLUS WiFi simultaneously) and that seemed to get me the open port on the router with proper port forwarding (double NAT from the Orbi being still non-functional without enabling bridge mode) while at the same time being able to access the home network running on the Orbi to serve my home attached devices (that are all on the Orbi home network). Bit of a kludge, but it got both my home network devices and ARC running simultaneously. Thanks for your response.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.