ARC doesn't connect to core located on my QNAP NAS

Roon Core Machine

Core version 2.0 (build 1128) production located on my NAS : QNAP (QTS 473)
Control version 2.0 (build 1128) production located on my Imac OS Catalina 10.15.7

Networking Gear & Setup Details

NAS connected to Synology Router with ethernet wire
Imac connected to Synology Router with ethernet wire + wifi

Connected Audio Devices

Use a DAC

Number of Tracks in Library

125 000 tracks

Description of Issue

I am unable to get ARC to connect to my core which is on a QNAP NAS.

I tried with the Automatic Configuration → Unsuccessful

I followed all instructions of the ARC Port Forwarding troubleshooting FAQ

  1. I enabled UPnP on my QNAP NAS and on my Synology router. The mapping is OK

  2. I tried the Manual Port Forwarding with the static IP address of my Roon core located on my NAS
    I created a new port forwarding rule in your router that uses these 3 pieces of info
    IP address: The IP address of my roon core
    LAN/Private/Internal Port: Port 55000
    WAN/Public/External Port: Port 55000

I tried unsuccessfully several ports (35575 / 55002 / 55000 / 65000)

The error message is :

I also followed instruction in this thread

I reinstalled codecs of my QNAP System’s ffmpeg binary that had been stripped by the update.
At the beginnning, it was indicated “System default”
ROON3

So I downloaded ffmpeg for amd64 architecture on johnvansickles website
ffmpeg-git-amd64-static.tar.xz - md5

I extract the ffmpeg file, copied it to my RoonOnNAS/bin folder (which was emptied) and restarted my Roon Server
Afterwards the QNAP message was different : User supplied version

To be exhaustive, I tried with / without activating

  • NAS antivirus
  • NordVPN on my iMac

I also tried from my Android phone (still unsuccessfully)

:sos:I don’t know what to do as I don’t have any technical skill / knowledge (port setting, protocol, etc.)
I’m all the more disapointed that I specially updated my roon versions + upgraded my iMac to benefit from ARC capabilities.

:pray:Thank you in advance for your precious help ! :crossed_fingers:

A post was merged into an existing topic: Can’t connect ROON ARC with my BT Smarthub 3

I also tried to open firewall port on Synology as well, as indicated on thread link below.
But still doesn’t work :smiling_face_with_tear:
(Even with anti virus + VPN turned off)

ANY GOOD IDEA TO SOLVE MY PROBLEM ?

Hi @Alexis_UZAN,

Thank you for your diligent patience over the last few weeks as we’ve worked to respond to every ARC-related issue.

Diagnostics suggest you haven’t been able to configure port forwarding manually in the interim - is that the case? If so, it’s likely the result of your service provider having implemented carrier-grade NAT. Your routable IP address is either formatted incorrectly (IPv6), or dynamically assigned in such a way that the Core can’t keep track. So, even with UPnP enabled, the same error might result.

I recommend you contact your ISP directly. Generally, reaching out to your service provider to ask if they support port forwarding will be enough to prompt them to explain their implementation and offerings (or lack thereof!).

If you’d like to be more specific, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

NordVPN is one of many unofficial workarounds for users in your position. Please take a look through our #tinkering and #roon sections, where users have accumulated a range of solutions.

We’ll be watching for your response.

Hi Connor,

Thank you :pray: for your reply but I still have (another) issue :sos:

After changing some settings on my router and isp configurator, I made some progress. :clap:
On my Imac, the Roon core has been now successfully configured for ARC when I reset the port connection. The ARC section has the “ready check” checked (no more error message) :+1:

But ARC app installed on my android phone and also on my Ipad are UNABLE to find my Roon Core. :sob:

  • It displays correctly my Roon library located on my NAS which has a ready status
  • when I click on connect, a message says « 1st synchro with roon core server»
  • afterwards there is an endless “searching” message, even though Roon says ARC is “Ready”.

No change even if I reset ARC roon port in ARC section, restarted my Roon Core, rebooted my internet box and Synology router, and even reinstalled ARC app on my Android phone

Whereas

  • the regular (non-ARC) Roon Remote app installed on my Android phone & ipad are Ok and can remotely connect to my Core and allow me to control my roon library.
  • The roon server on my NAS is OK and running without problems

My ISP is a french Local phone company, Sosh (belonging to Orange group, its “low cost” brand)

As I’m not an IT technician, I made following settings but without knowing / controling impacts (I’m sure some are useless, and maybe “dangerous” as potential open door on my NAS :grimacing:)

On my QNAP NAS → activation of UPnP service have been set to enable

On my Synology router, all following Port forwarding +DMZ settings




On my ISP interface







Thank you by advance for all your support and any help :pray: :raised_hands:

I read on some threads that could come from library issue. (??)
I had issue when upgrading to roon 2.0 and had to rebuild my library from a former back up (+250 K tracks / 1/2 day to rebuild).

Hi @Alexis_UZAN,

Thank you for your incredibly detailed response. I have three quick notes as follow up as I believe we’ve diagnosed the situation from your above post:

  1. As far I’m aware, Sosh (as well as rest of the Orange group in France) has implemented IPv6 for the majority of their residential clients at this point. The initiative was already well underway five years ago (see this article).

Diagnostics from our end confirm there is an additional layer of network address translation (MultipleNAT) blocking the port forward, even if Roon → Settings → ARC doesn’t display it. This is likely at the level of your service provider, since you appear to have correctly configured your network.

I recommend you reach out to your service provider, Sosh, directly, and pass along these questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a routable IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?
  1. Please disable the DMZ rule you have set in the above screenshots, as it’s likely not required for port forwarding with ARC, and may disable your router’s ability to filter unwanted inbound requests. This is a security risk you don’t need to take.

  2. Lastly, I can report that your issue doesn’t appear to be due to library size. This is a known limitation with ARC, but usually libraries up to 400-450k tracks perform well, unless there’s an unrelated hardware/networking issue with the storage location or your connection to ARC.

We’ll be standing by with next steps once you’ve had a chance to contact your ISP. I apologize that this situation is drawn out for you.

Hi Connor,

Many thanks for this reply.

My ISP (low cost) took hours through instant messaging to answer to your questions. Finally they say that it was outside its area of competence :sob:
I think it was more a sales/generalist profile than a technician…

So, I asked user community and I got this first answer to your questions :
- NAT is automatically enabled on the internet Livebox, you can’t disable it or have a “bridge” mode
- it doesn’t seem to me that there is a multiple NAT; in my opinion, if you configure the NAT on the box, the port(s) is/are accessible from outside
- on the other hand, no fixed IP address is possible, it can change at each reboot of the box
- on VSDL / fibre accesses, you have a range of IPv6 addresses in addition to the IPv4 address, and no IPv6 NAT

What does it inspire you ?? :sos:

Many thanks again for your active support and precious help :pray: :raised_hands:

1 Like

Hi @Alexis_UZAN,

The response time on our end is less than exemplary again, but we’re working to catch up. Thank you again for your continued patience.

The responses you’ve shared from your service provider’s user community suggest that double-NAT isn’t the issue. Reviewing your firewall settings more deeply, it’s likle that the Synology router firewall is blocking inbound connections from ARC to your Core. Please see the security setting “Medium” below from your screenshot:

I suggest you customize the firewall instead, allowing exceptions for the ports specified in your port forwarding rules, or Roon/ARC, depending on the nomenclature of the firewall rule assignments.

A security setting interfering with ARC’s connection is consistent with all the error messages you’ve received since auto-configuration first displayed that it had connected. Please keep us posted once you’ve changed the firewall settings, and we’ll support further if that doesn’t resolve the issue.

Hi Connor,

Many thanks for this reply.
Unfortunately, the new settings described below don’t solve my ARC connexion problem.

I tried 4 things

  1. Define specific filtering rules for the firewall of my internet box (Sosh) as described below
    Add IPV4 rules with IP address + Port address of my Roon core as destination and source
    I didn’t reboot my internet box → ARC access still KO from ARC App



  1. Config 1 above following firewall setting for my Synology router
    I rebooted my internet box + router → ARC access still KO from ARC App

  1. Config 2 above with firewall setting for my Synology router for ALL source and destination IP addresses → ARC access still KO from ARC App

  2. Config 3 above with firewall of my internet box at medium level (ie without any specific rules) → ARC access still KO from ARC App

What does it inspire you ?? :sos:

Many thanks again for your active support and precious help :pray: :raised_hands:

When I go to RoonARC settings it still tells me that there is an error connecting and ARC won’t work, despite me opening up the port.

However, and it’s a big however, when I am away from my home, I can play my music through the ARC app on my iPhone. How does that work.