Arc Failure with TP - Link Router

I have the same router, and I have an AT&T router, the 5268AC. The AT&T router is running in DMZ+ mode, and the TP-Link is behind it. What do I do next?

@Ryan_Herrera1, I moved your post to the Port Forwarding category. What message are you seeing from Roon’s Settings → Roon ARC tab?

Assuming the double-NAT error is eliminated by placing the 5268AC in DMZ+ mode pointing to the TP-Link router, can you first enable UPnP on the TP-Link router and see if it autoconfigures ARC? If not, then the next attempt would be to create a TCP port forwarding rule using the Roon ARC port number on the TP-Link router and point it to the LAN IP address of your Roon Core.