ARC - inaccessible

Roon Core Machine

Networking Gear & Setup Details

Router: ASUS RT-AX56U

The Roon Core is on a dedicated machine which has a cabled ethernet connection to the router.

It plays happily across the home network and also with TIDAL service streaming.

Connected Audio Devices

Number of Tracks in Library

80,000

Description of Issue

Difficulties with ARC setup

The diagnostics data for RoonSet up is
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“45.#7.##.##”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

As this seems to be a public forum I have put ## in some of the external ip address numbers, above.

I have enabled port forwarding with an internal port of 55000 with the Roon Core machines static internal LAN IP address, with TCP protocol selected. Port trigger is also enabled in the router, though there is not any entry in the port trigger list.

I do not normally have UpnP enabled on the router for security reasons. If I enable UPnP, with the router “Enable secure UPnP mode” option enabled, I still get a Roon ARC error, with the following somewhat different diagnostics data::
{
“connectivity”: {“status”:“NetworkTimeout”,“status_code”:998,“error”:“”},
“external_ip”: {“actual_external_ip”:“15#.#6.###.##”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“###.1.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Curiously the external ip address differs above depending on whether or not UPnP is enabled.

If I enable UPnP, with the router “Enable secure UPnP mode” option disabled, I still get a Roon ARC error, with the following somewhat different diagnostics data::

{
“external_ip”: {“actual_external_ip”:null,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“###.1.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

The internal server ip is correct, though I

Networking Gear & Setup Details

ASUS router ASUS RT-AX86U

Roon Core Machine

Roon rock on an Intel NUC

Description Of the issue

I’m getting a similar error, with the ASUS router ASUS RT-AX86U.
Running the roon rock on an Intel NUC

The diagnostics data for Roon ARC Set up is

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxx.xx.xx.xx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.50.1”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}
}

I tried the following steps

  1. Disabled NAT and UpnP but got eact same error
  2. Enabled NAT and UpNP, but disabled the firewall in the router settings, but got the exact same error
  3. With NAT, UpNP enabled and firewall on router disabled, I configured port forwarding as below
    External Port - 55000
    Internal Port - 55000
    Roon core IP - 192.168.50.189
    Proticol - TCP

Again got the exact same error :frowning:

I have the same exact issue and same settings as above, as well as having attempted the same troubleshooting steps. To give a bit more context. I have an Asus RT-AX88U sitting behind an ATT provided modem, which is in bridge mode.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“XXX.XX.XXX.31”,“router_external_ip”:“XXX.XXX.X.64”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.50.1”,“found_upnp”:true}
}

Similar Issues with Sonicwall with

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“7#.2##.###.###”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}