ARC issue with Linksys WRT1900AC on Optimum Internet

I am running Roon Nucleus connect via ethernet to the Router

The Router is a Linksys WRT 1900AC connected to a router-modem combo provided by Optimum ISP. The wifi part of the Optimum router-modem combo is disabled.
I am not using VPN at the router level.

I am getting the following error message when configuring ARC:

I looked through another post talking about the Linksys mesh router and followed a lot of the tips:

  1. made the Roon nucleus have fixed IP.
  2. turned UPnP off and then back on
  3. turned UPnP off and set up manual port forwarding
  4. turned UPnP back on and kept manual port forwarding just to give it a try.

None of it made a difference.

I am wondering if anyone can make sense of the error message. I suspect that my router being connected to the router-modem combo and that it changed the IP address of all my device from the standard 192.168.xx.xx to the 10.140.xx.xx may have something to do with it.

Thank you all!

1 Like

Hey @Yizhi_Shan,

Thanks for writing in, and my apologies for the delay in my response. I’d love to dig into your modem router combo a bit more and see what options we have in terms of setting it up in bridge mode. Are you able to provide the specific model number?

Getting in touch with your ISP might be a good next step as well, to see what they might be able to help with in that regard, too.

Hi benjamin,

The Modem/Router Combo is Altice UBC1326. Connected to the Altice is a Linksys WRT 1900AC. All my devices are connected to the Linksys WRT 1900AC.
I checked both devices and UPnP are enabled on both.

Also, I tried to call the ISP, but they had no idea what I was talking about…

If this helps. I run a Plex Server and a Synology NAS drive. I can access both of those outside of my network.

Thank you!

Hey @Yizhi_Shan,

After reading up on the UBC1326 combo device, it looks like setting it to bridge mode may work by setting it to port 1. Other reports mention needing to call your ISP to request a static IP.

Your ISP should be able to give you more context into whether or not you have a static IP or not, and if they can assign you one.

Can you confirm you have the same port numbers from your Roon settings > Arc to your routers with port forwarding enabled? I would also ensure that your Plex server is not using the same port number or range of reserved ports that you’re trying to use with Arc.

Hi @benjamin,

I called the ISP and confirmed that the UBC 1326 is in bridge mode.
The Linksys WRT 1900AC router is plugged into the port 1. Its IP Address on the Modem is static at 192.168.1.xxx. The router’s IP Address in its system is 10.140.21x.xx.
The Roon Nucleus has a static IP Address of 10.140.211.xxx.
I confirmed that it is not the same as the PLEX server and the NAS drive.

I tried to plug the Roon Nucleus directly into the Altice UBC 1326, and that doesn’t work, most likely due to the bridge mode.
Customization of the Altice UBC1326 is very limited, and I think this IP address change is what is screwing up ARC.

Thank you for helping.

If you’re having trouble connecting your Linksys WRT1900AC to the internet, there may be a fix.

First, make sure that the Linksys WRT1900AC is properly connected to your network and your computer. If you’re having trouble connecting wirelessly, make sure that your Wi-Fi is turned on and connected to the network.

Next, test whether you can connect to the internet using a different device. If you’re using a computer that is not the one that you bought the router for, you may be able to connect to the internet using a different device.

If you’re still having trouble connecting to the internet, try the following steps.

First, make sure that the Linksys WRT1900AC is properly connected to your network and your computer.

Next, open the Linksys Settings app and click on the Wireless tab. Under the Basic Settings section, make sure that the Network Type is set to Automatic and that the Wireless Mode is on.
This may help you to fix the issue. If still not working find the solution at Linksys router not working.

1 Like